Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

No Display and no pos

patatas216
 Share

My pc starts for sometime then the screen goes blank and the fan slows down. what can I do to fix his? thank you

Link to comment
Share on other sites

Link to post
Share on other sites

Does your PC have an HDD indicator? Could you tell me what happens with the HDD indicator from a cold reboot

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, MagnumOpus said:

Does your PC have an HDD indicator? Could you tell me what happens with the HDD indicator from a cold reboot

just blinks fast then pc boots. after 3 mins or so the screen goes blank then the cpu fan slows down

Link to comment
Share on other sites

Link to post
Share on other sites

This could be a RAM issue, PSU, a whole multitude of things, any more info you can give us, like what you were doing at the time when your PC shuts down?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, wayneski9 said:

This could be a RAM issue, PSU, a whole multitude of things, any more info you can give us, like what you were doing at the time when your PC shuts down?

also shutdown when I play games but when just doing basic stuff it doesnt shutdown it will last for about 15 mins. then shutdown 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, patatas216 said:

also shutdown when I play games but when just doing basic stuff it doesnt shutdown it will last for about 15 mins. then shutdown 

Hmm, It sounds like I might've had this problem before, as my PC used to do this, and I replaced the PSU and it fixed itself, this could be something different for you.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, wayneski9 said:

Hmm, It sounds like I might've had this problem before, as my PC used to do this, and I replaced the PSU and it fixed itself, this could be something different for you.

i will try to format it. driver issue?

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, patatas216 said:

i will try to format it. driver issue?

Nope, hardware failure. 

 

For you i'd suggest reseating your ram, trying new ram, a new PSU, making sure your connectors are in properly.

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, wayneski9 said:

Nope, hardware failure. 

 

For you i'd suggest reseating your ram, trying new ram, a new PSU, making sure your connectors are in properly.

 

will try to change the ram first then psu. thank you for the help!

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, patatas216 said:

also shutdown when I play games but when just doing basic stuff it doesnt shutdown it will last for about 15 mins. then shutdown 

If i'm right there will be no more activity on the HDD indicator of that. Check the CMOS battery. Could be the CMOS battery.

 

If not, Did you recently upgrade RAM or something like that?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×