Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Computer won't boot

I just recently took out my graphics card and upgraded it to a rtf 2080ti and it won't display anything.Any tip

Link to comment
Share on other sites

Link to post
Share on other sites

try plugging into the motherboards video outputs to get into the pc the remove the old drivers for you old GPU and install the new ones for the 2080ti off nvidia website. also when you say it wont display anything does the pc turn on and gpu fan spins and monitor picks up a signal but its just a blank screen or does it pick up no signal

 

 

i7-8700k @ 5GHz || MSI Z370 Sli Plus || Gigabyte G1 Gaming GeForce GTX 1080 || 250GB 970 EVO NVMe SSD, 250GB WD Blue SSD, 1TB WD Black HDD, 4TB WD Blue HDD

Corsair Vengeance RGB CL141818 3200Mhz 2x8GB || Corsair Obsidian 500d RGB SE || Corsair H150i || Corsair RM750x || Acer Predator XB241H, Acer G257HL

Link to comment
Share on other sites

Link to post
Share on other sites

I reckon its a driver problem, what cpu do you have does it have integrated graphics? 

 

i7-8700k @ 5GHz || MSI Z370 Sli Plus || Gigabyte G1 Gaming GeForce GTX 1080 || 250GB 970 EVO NVMe SSD, 250GB WD Blue SSD, 1TB WD Black HDD, 4TB WD Blue HDD

Corsair Vengeance RGB CL141818 3200Mhz 2x8GB || Corsair Obsidian 500d RGB SE || Corsair H150i || Corsair RM750x || Acer Predator XB241H, Acer G257HL

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Picklestine said:

I reckon its a driver problem, what cpu do you have does it have integrated graphics? 

Drivers don't come into play before the operating system starts up. When there's not even any display for the BIOS portion of the bootup it's not a driver problem.

 

29 minutes ago, gamegambier101 said:

I just recently took out my graphics card and upgraded it to a rtf 2080ti and it won't display anything.Any tip

Full specs please?

 

Have you tried switching PCIe slots? All power cables connected properly?

PC Specs - AMD Ryzen 5 5600X MSI B550M Mortar 16GB Crucial Ballistix DDR4-3600 @ CL15 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

 

Link to comment
Share on other sites

Link to post
Share on other sites

Its a problem with the GPU itself, assuming that you installed it correctly. Where was the card purchased? I recommend you return the item. If it was a driver problem you'd still have an image when Windows first boots, it would just be an extremely low resolution, then after about 10 minutes Windows installs a generic driver to give you a better display (Windows 10).

There have been several thousand reports of RTX cards dying already.

Intel Core i7 9700F / Cooler Master 212 Evo / GeForce GTX 1660 SUPER / 16 GB G.SKILL RAM @ 2666MHz / GA-B365M-DS3H / EVGA 500w PSU

HP Pavilion Gaming 15 / Ryzen 5 4600H / GeForce GTX 1050 / 8 GB @ 3200MHz

 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×