Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My GPU Black screens

kumzrocks08
 Share

I have this issue with my grahics card, 2 days ago i updated my gtx 980ti drivers, and whilst in a middle of a pubg game , I black screened to a point that i had to physically restart the system.I tried launching pubg again ,thinking it was a one off issue as i had been playing pubg for about 3 hours at this point .but whenever i launched 4 seconds in it kept black screening.I tried to roll back the update,didnt solve the problem, I reseated the graphics card ran ddu and reinstalled old drivers,problem persisted. with the help of @joelrules I had changed the PCIE lane to the 8 bit one and Joel ran ddu and installed older drivers,the problem was somewhat remedied (i.e it ran furmark , ran Heaven benchmark longer before crashing again,ran pub till the lobby music was audible and crashed again) at the point I reseated the graphics card to the 16 bit lane and we reinstalled drivers ( after running ddu) the problem again improved but still crashed heaven and pubg (heaven 4 secounds in and pubg 6 seconds after loading) at this point we were baffled and concluded it is definatly the graphics card .So in a bid to find the underlining issue,I installed aoe 2 HD and ran it , it crashed 2 minutes in game,Using device manager ,I disabled the grahics card and ran again,the game didnt crash and I played it for an hour (with some frame drops but it is to be expected ) btw I won against AI incase you were wondering ,does this show that the gpu is definatly the problem ?
 
 
 
btw my grahics card is the gigabyte gtx 980ti gaming G1
 
 
 
cpu intel 6700k
 
 
 
MB: gigabyte z170 gaming 7
 
 
 
ram : hyperx fury ddr4 16b (2*8gb)
 
 
 
PSu: Rm650x
 
 
 
operating system : windows 10
 
 
 
any help will be much apretiated
Link to comment
Share on other sites

Link to post
Share on other sites

I have the same problem but with a gtx 1050, started happening right after a driver update too, and going back told old drivers doesn't fix the problem.

Link to comment
Share on other sites

Link to post
Share on other sites

I sent it to a shop, so far I have been told that the gpu is fine, so it could be a mobo issue in my case, which is is aids cus where am I going to get a z170 mobo now, will any of the newer motherboards backwards compatible? 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×