Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Wi-Fi Replacement Issues

I've got a Latitude E5570 with a sketchy wireless card that needs to go. I fished out a Vostro 3558 and salvaged it's wireless for the Latitude. The card is installed correctly. However, when I try to install the drivers, the installation fails with the message

 

"Installation Blocked"

"This software package cannot be installed on your system"

 

I'm positive I have the correct drivers but they still refuse to install. Any help would be appreciated

Link to comment
Share on other sites

Link to post
Share on other sites

do you need the driver for the card to work? on windows 10 for me, ive tried about 4 wireless cards and they all work without installing any drivers (windows automatically installs them for you)

 

right click and try to install as administrator

 

what windows version and what wifi card?

Ryzen 5 3600 stock | 2x16GB C13 3200MHz (AFR) | GTX 760 (Sold the VII)| ASUS Prime X570-P | 6TB WD Gold (128MB Cache, 2017)

Samsung 850 EVO 240 GB 

138 is a good number.

 

Link to comment
Share on other sites

Link to post
Share on other sites

 

1 minute ago, themctipers said:

do you need the driver for the card to work? on windows 10 for me, ive tried about 4 wireless cards and they all work without installing any drivers (windows automatically installs them for you)

 

right click and try to install as administrator

 

what windows version and what wifi card?

Windows 7. I looked up the hardware ID of the card and its an Intel Dual-Band Wireless-AC 3160

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Hameck said:

 

Windows 7. I looked up the hardware ID of the card and its an Intel Dual-Band Wireless-AC 3160

 

5 minutes ago, themctipers said:

do you need the driver for the card to work? on windows 10 for me, ive tried about 4 wireless cards and they all work without installing any drivers (windows automatically installs them for you)

 

right click and try to install as administrator

 

Ryzen 5 3600 stock | 2x16GB C13 3200MHz (AFR) | GTX 760 (Sold the VII)| ASUS Prime X570-P | 6TB WD Gold (128MB Cache, 2017)

Samsung 850 EVO 240 GB 

138 is a good number.

 

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, themctipers said:

right click and try to install as administrator

Tried that...

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Hameck said:

Tried that...

 

8 minutes ago, themctipers said:

do you need the driver for the card to work? on windows 10 for me, ive tried about 4 wireless cards and they all work without installing any drivers (windows automatically installs them for you)

 

Ryzen 5 3600 stock | 2x16GB C13 3200MHz (AFR) | GTX 760 (Sold the VII)| ASUS Prime X570-P | 6TB WD Gold (128MB Cache, 2017)

Samsung 850 EVO 240 GB 

138 is a good number.

 

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, themctipers said:

do you need the driver for the card to work? on windows 10 for me, ive tried about 4 wireless cards and they all work without installing any drivers (windows automatically installs them for you)

Yes. Win 7 does not have basic drivers that work with this card

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×