Jump to content

Underperforming 980Ti Please Help

PCGUY11

In a matter of 24 hours my 980Ti performance went from 100% to 10%

 
What I downloaded 12/10
-League of legends (250 FPS Max Settings)
-Heaven Benchmark (60 FPS Ultra Settings)
What I downloaded 12/11
-Skype
-Steam
-CS:GO (@Steam) - Lowest video settings under 50 FPS at times I can see the lag
-Vindictus (@Steam) - Couldn't even handle default medium graphics (Under 60 FPS)
-League of legends now became under 60fps at max settings
-On the Heaven Benchmark it was still 60FPS at Ultra Settings... (This confuses me, everything else went down in performance??)
Other factors
-Windows updates auto (I've always been told by my dad never to do this, but everyone on the internet says to)
Any way I can do a Factory Reset on Windows 10 without messing something up?
 
I'm 100% sure its a 980Ti, MSI brand name I can see in the case window and in device manager it says 980Ti.
Link to comment
Share on other sites

Link to post
Share on other sites

Have you been overclocking the card?  What speeds and voltages is your card running at when you play games?

i5-4690k@4.5GHz || MSI GTX 970 || MSI z97 Gaming 5 || NZXT Kraken x61 || WD Black 1TB || Crucial MX100 || 8GB Corsair Vengeance Pro || Corsair RM750 || NZXT H440 || Corsair k70 RGB mx browns || Acer H236HL || ViewSonic VX2255wm-4

Link to comment
Share on other sites

Link to post
Share on other sites

1. Check for any and all updates for your OS or Drivers

2, Reboot PC

3. Remove any overclocks (if present)

4. Reinstall Drivers

Specs: CPU - Intel i7 8700K @ 5GHz | GPU - Gigabyte GTX 970 G1 Gaming | Motherboard - ASUS Strix Z370-G WIFI AC | RAM - XPG Gammix DDR4-3000MHz 32GB (2x16GB) | Main Drive - Samsung 850 Evo 500GB M.2 | Other Drives - 7TB/3 Drives | CPU Cooler - Corsair H100i Pro | Case - Fractal Design Define C Mini TG | Power Supply - EVGA G3 850W

Link to comment
Share on other sites

Link to post
Share on other sites

Install the new NVIDIA drivers. I had the same issue a couple of days ago.

Intel Core i7-6700K | Corsair H105 | Asus Z170I PRO GAMING | G.Skill TridentZ Series 16GB | 950 PRO 512GB M.2

 

Asus GeForce GTX 980 Ti 6GB STRIX OC | BitFenix Prodigy (Black/Red) | XFX PRO Black Edition 850W

 

 

My BuildPCPartPicker | CoC

 

Link to comment
Share on other sites

Link to post
Share on other sites

Install the new NVIDIA drivers. I had the same issue a couple of days ago.

Could you by any chance link me? when I go to device manager and clicked on my980ti to check for updates, it said it was up to date.

Link to comment
Share on other sites

Link to post
Share on other sites

Could you by any chance link me? when I go to device manager and clicked on my980ti to check for updates, it said it was up to date.

 

Use GeForce Experience.

Intel Core i7-6700K | Corsair H105 | Asus Z170I PRO GAMING | G.Skill TridentZ Series 16GB | 950 PRO 512GB M.2

 

Asus GeForce GTX 980 Ti 6GB STRIX OC | BitFenix Prodigy (Black/Red) | XFX PRO Black Edition 850W

 

 

My BuildPCPartPicker | CoC

 

Link to comment
Share on other sites

Link to post
Share on other sites

Use GeForce Experience.

Should i delete existing driver and install new one?

Link to comment
Share on other sites

Link to post
Share on other sites

Should i delete existing driver and install new one?

 

Nope. Just update.

Intel Core i7-6700K | Corsair H105 | Asus Z170I PRO GAMING | G.Skill TridentZ Series 16GB | 950 PRO 512GB M.2

 

Asus GeForce GTX 980 Ti 6GB STRIX OC | BitFenix Prodigy (Black/Red) | XFX PRO Black Edition 850W

 

 

My BuildPCPartPicker | CoC

 

Link to comment
Share on other sites

Link to post
Share on other sites

Nope. Just update.

My Driver is up to date

 

Is there anything else I can try?

Link to comment
Share on other sites

Link to post
Share on other sites

My Driver is up to date

 

Is there anything else I can try?

 

Did you check for updates in the "Drivers" tab?

 

post-233981-0-07561300-1449896234_thumb.

Intel Core i7-6700K | Corsair H105 | Asus Z170I PRO GAMING | G.Skill TridentZ Series 16GB | 950 PRO 512GB M.2

 

Asus GeForce GTX 980 Ti 6GB STRIX OC | BitFenix Prodigy (Black/Red) | XFX PRO Black Edition 850W

 

 

My BuildPCPartPicker | CoC

 

Link to comment
Share on other sites

Link to post
Share on other sites

Yes its up to date.

 

What are your temperatures on both the CPU and GPU?

Intel Core i7-6700K | Corsair H105 | Asus Z170I PRO GAMING | G.Skill TridentZ Series 16GB | 950 PRO 512GB M.2

 

Asus GeForce GTX 980 Ti 6GB STRIX OC | BitFenix Prodigy (Black/Red) | XFX PRO Black Edition 850W

 

 

My BuildPCPartPicker | CoC

 

Link to comment
Share on other sites

Link to post
Share on other sites

My Driver is up to date

 

Is there anything else I can try?

In the options menu you can use beta drivers. I had a similar issue playing LOL the other day where my 980 was dipping below 60fps. Mine just seem to come good without me doing anything

...

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

That odd.. did you update all your drivers from your motherboard/cpu manufacturer.. even i get better FPS with my FX6300.  

Magical Pineapples


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Link to comment
Share on other sites

Link to post
Share on other sites

That odd.. did you update all your drivers from your motherboard/cpu manufacturer.. even i get better FPS with my FX6300.  

Im not entirely sure, does that make a difference? I don't recall updating drivers myself, must of been done automatically by my system or by manufacturer (CyberPowerPC)

Link to comment
Share on other sites

Link to post
Share on other sites

Im not entirely sure, does that make a difference? I don't recall updating drivers myself, must of been done automatically by my system or by manufacturer (CyberPowerPC)

.... Pre Built. They is chance the GPU/part is Refurbished and that would be the reason it not performing too well. Have you tried using a benchmark such as 3DMark or Unigine Heaven and post your benchmark here or compare with reviewers website benchmarks. If the score is similar it should be game optimized problem or drivers but if it is not it should be the hardware problem.   

Magical Pineapples


 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×