Jump to content

My pc suddenly wouldn't turn on

So basically my pc has been working fine lately, but i went away for 2 days out of the city for college graduation presentations and when i came back my pc wouldnt turn on at all..i tried switching it on and off through the psu i tried plugging it directly to the wall nothing..as if its not connected to any power nothing even lights up

 

Then i tried the classic "unplug then plug back" everything on the motherboard trick and i replaced my thermal paste in the process to and it booted to bios saying it failed to boot and i chose "restore default settings and rebooted then it worked?..i dont get what happened, I also used superposition at extreme and no crashes or anything happened so not the gpu, tried playing tekken 8 for long times and nothing happened so..any ideas? 

 

Link to comment
Share on other sites

Link to post
Share on other sites

What are the full system specs includes the brand and model of the PSU?

Link to comment
Share on other sites

Link to post
Share on other sites

You chose restore default settings in what? The BIOS? Or Windows? Monitor your PC for a while and make sure that doesn't happen again, but it sounds like just a weird freak case of either Windows derping, your storage drive starting to fail, or some weird power event with your PSU. 

 

You could even try running some benchmarks to see if your PC is currently stable.

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, damned said:

You chose restore default settings in what? The BIOS? Or Windows? Monitor your PC for a while and make sure that doesn't happen again, but it sounds like just a weird freak case of either Windows derping, your storage drive starting to fail, or some weird power event with your PSU. 

 

You could even try running some benchmarks to see if your PC is currently stable.

I ran superposition and it didn't crash or shut down on me, i ran a number of games and played a bit and nothing else as well.

And by default settings i meant in the bios. Both my storage drives are healthy and okay

And my psu has nothing wrong with it i believe

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, --SID-- said:

What are the full system specs includes the brand and model of the PSU?

I5 11400

Rtx 3070 TUF

16 GB ram

256 gb ssd

1tb hdd

H510M-S2H motherboard

Coolermaster MWE V2 230V 650W 

Had this setup for years and it always was good to me and treated it well, cleaning in time, taking care of it not using it in hot weathers etc.

Link to comment
Share on other sites

Link to post
Share on other sites

13 hours ago, FoxyZey said:

I ran superposition and it didn't crash or shut down on me, i ran a number of games and played a bit and nothing else as well.

And by default settings i meant in the bios. Both my storage drives are healthy and okay

And my psu has nothing wrong with it i believe

Then it looks like your BIOS just went derp or some random setting like secure boot or something was changed and a restore to defaults fixed it. Should be nothing to worry about!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×