Jump to content

aoc CU34G2X appearing as NV-Failsafe

So recently my aoc CU34G2X started appearing as nv-failsafe while using it via dp cable. It seems to work fine via hdmi and is able to be ran at its supported 3440x1440 @100hz. But while using it via dp cable the only resolution that it's available in is 640x480 @60hz. I have wiped nvidia drivers with DDU twice, have updated monitor firmware,have tried to use older nvidia drivers, have tested multiple dp cables(all of them worked fine on my Samsung odyssey g5 32").

While using monitor with dp cable I tested it with EDWriter and EDID number couldn't be read but while using monitor via hdmi the EDID number was read perfectly fine. I have tried to make custom resolution of 3440x1440 @144hz via Nvidia control panel and it seem to pass the test but resolution never saved when I clicked yes to save it. When it does save some games do not recognise custom resolution and run at 640x480. 

I can only assume that something is wrong with the DP ports on my monitor. 

I already have contacted nvidia and they were not able to help. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now