Jump to content

Computer not shutting down properly when boot drive is in RAID mode

i’m working on a new build with the following pertinent specs:

CPU: AMD Ryzen 7900X3D

MoBo: Asus Crosshair X670E Hero

Storage: 4x Hynix P41 Platinum 2TB NVMe SSD’s in RAID 10 (via AMD RaidXpert2)


For whatever reason, my build has serious power management issues. I’ve tried installing Windows 11. The install itself seemingly starts out okay - at least in the sense that I install the AMD RAID drivers according to the manual and Windows sees my RAID setup. Install starts fine till we get to “Windows will restart in 10 seconds”. Countdown ends and… nothing, OS just locks up, never restarts. I have to manually power down. This same thing happens every time when the installation reaches a checkpoint where a restart must be done. Just hangs and never restarts properly. That said, with enough manual intervention, we get a successful install.


However, in daily use, I’ve noticed several issues that only pop up when the computer needs to power down.

  • When shutting down, restarting, or, the OS itself shuts down, but the lights and fans continue spinning and the power light stays on. I have to manually intervene and shut it off.
  • Same as above when restarting. I have to manually hit restart after the OS goes dark because the computer itself doesn’t actually power down.
  • When going into sleep mode, the computer sometimes wholesale shuts down. It actually shuts down. It doesn’t go sleep, it shuts down. But it shuts down for real.

I’ve tried the following, to no avail:

  • Fiddling with turning fast boot off in BIOS, turning fast startup off in Windows
  • Disabled “Launch CSM” in the BIOS
  • Tried updating the BIOS firmware
  • Even formatted and re-installed Windows from scratch. Exact same problems keep happening.What could I be missing here? It’s clearly not just my Windows installation.


Even changing the RAID arrays to different combinations of NVMe disks in RAID 0 or RAID 1 doesn’t work. Even single disk volumes that are non-RAID with NVMe RAID enabled refuse to work. However, once I disable NVMe RAID and re-install windows, none of these issues occur. Everything goes well and none of the power management issues crop up. It is all good.


What am I missing here? I installed the correct AMD RAID drivers for NVMe, so it shouldn’t be doing that. I really wanna get this one working in RAID.


Link to comment
Share on other sites

Link to post
Share on other sites

I don't understand why people are using RAID to begin with, it has no real benefit for the boot drive IMO.

Then for something like video editing, software RAID is more practical so it can migrate over if you switch between Intel and AMD at some point.

Router:  Intel N100 (pfSense) WiFi: Zyxel NWA210AX (1.44Gbit peak at 160Mhz 2x2 MIMO, ~900Mbit at 80Mhz)

Switches: Netgear MS510TXUP, Netgear MS510TXPP, Netgear GS110EMX
ISPs: Zen Full Fibre 900 (~915Mbit down, 115Mbit up) + Three 5G (~900Mbit down, 115Mbit up)

Folding@home Recent WUs               
Upgrading Laptop CNVIo WiFi cards to PCIe

Link to comment
Share on other sites

Link to post
Share on other sites

Everytime I have done hardware RAID, I ended up using a separate PCI RAID Controller to do it.  Software raid is total crap shoot, and windows storage pools are often the best way to do it.


Also the last time I got it working via a motherboard, I set it up in bios and then installed windows with the raid already in place.  However it keep dropping drives, so I ended up going with the PCI Controller instead.


EDIT - I have done RAID 6 or 5 FYI for a NAS server (rebuild after we got better power and better drives) and raid 0 back when there were no m.2 drives.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now