Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows 11 Dual Screen Switching

Selestialnorre
 Share

I run Windows 11 on my desktop with two 4k TCL TVs and when I'm gaming on a dark game, I like to shut the lights off and turn the right screen off. I run the game in full screen mode, but when I turn the second monitor off, the game window will shrink to be smaller on the screen with black boarders around all sides (this is animated, so I know it's a feature) and then in a few seconds, it'll go back to normal. What causes this, is it normal, and how do I turn it off to ignore the second screen going off? Any solutions are appreciated.

Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...
On 5/19/2022 at 3:45 AM, Selestialnorre said:

I run Windows 11 on my desktop with two 4k TCL TVs and when I'm gaming on a dark game, I like to shut the lights off and turn the right screen off. I run the game in full screen mode, but when I turn the second monitor off, the game window will shrink to be smaller on the screen with black boarders around all sides (this is animated, so I know it's a feature) and then in a few seconds, it'll go back to normal. What causes this, is it normal, and how do I turn it off to ignore the second screen going off? Any solutions are appreciated.

Now that I am all setup with my dual screen configuration, I can answer you. 🙂 Hopefully, not too late.

 

It's Windows 11 animation that occurs when a display related event occurs (beside resolution change), such as screen rotation. The issue is that when your turn off your secondary TV, the TV disconnects from the video cable it connect to (I am assuming HDMI). Normally it should do it only when you turn on the TV.

You can disable animations but that will affect everything (all animations of the OS)

 

I have the same behavior with my setup. I have an LG and Dell screen.

The proper behavior is that when you turn off the screen, it does not disconnect with the video input it is currently on, nor when you switch inputs.

This will make Windows not do the zoom in/out animation.

 

Only when the monitor/TV is turned back on, it is expected that this animation occurs, as it needs to initialize with the GPU again (should not do it when you switch input back and forth).

 

If it were my guess, the TV manufacture and monitors implement this connection cut-off behavior on input change/turn-off  as a cost cutting measure. Doing like Dell, and the very few monitor manufactures (I think Samsung does it well, if I remember well), costs money due to the more complex circuit especially when you have multiple inputs. Basically, they use a basic switching circuit instead of a fancy display controller. In other words, the TV or monitor is designed for 1 input and they tag on a HDMI/DisplayPort dumb switch and calls it a day, instead of using a fancy controller driver that support multiple inputs at once, and can work with all at once.

 

I am noticing that monitors with proper implementation tend to have features like having 2 or 4 system displayed at once on the same screen (PBP and PiP), as they can't use a switch system, they need to use a fancy controller.

 

So anyways, that is your problem. There is no actual fix beside getting a new TV (same applies to monitor) that doesn't disconnect it's sources when switching off or inputs

 

Now, there is an exception on this. Some monitor and TV have power saving features, which, to save that fraction of wattage, cut off connection to the non-active input (TV off or input switched). Look if you have any eco-mode / power saving features on your TV and disable those. Look for "Deep Sleep" as well, and disable that. This COULD solve this behavior. If not, then yea... simple controller with a tagged on dumb switch. Nothing you can do about it. (By the way, LG monitors, even on their most premium monitors, cut corners like on your TV. They don't care, as no reviewers are looking at that)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×