Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PSU I think tripping on start up

 Share

Sounds like my PSU is tripping. I checked the connections at the PSU and motherboard and they r fine. I have it open unfinished for now. 

 

I changed out my case and the CPU cooler since my old cooler went bad. Everything else was fine before

Link to comment
Share on other sites

Link to post
Share on other sites

you're probably shorting somewhere.  Take the board out and run it on top of a cardboard box (motherboard box if you have it) to test.

 

If that works, double check everything before reinstalling.

Link to comment
Share on other sites

Link to post
Share on other sites

Could be weak capacitors losing their 'charge' when not running. Would cause such issues on startup until they fully charge (or keep tripping if they cannot).

OP: My PC cuts off and crashes. Is the 1000W PSU enough?  ME: 1000W is plenty, PSU or system board could be faulty. Get both tested.

OP: I don't think so, both parts were purchased last week.        😒  Why bother asking if you second-guess the advice?

Friends don't let friends use Apple.                                              NOTE: Recently diagnosed autistic. I don't intend to ruffle anyone's feathers.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×