Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't use X.M.P with Z690 Gaming X DDR4 (rev1.0)

As stated in the title.

I bought the motheboard and a i7 12700k. Installed everything and the PC boots just fine. I also installed W11.

RAM - Corsair Vengeance 4x8GB 3000Mhz.

 

However, RAM is running at 2133Mhz in Windows. If I enable XMP my PC won't boot, or if it does it sometimes bluescreens, turns off by itself. I also tried to run Escape from Tarkov and it either froze on me or crashed.

I thought it was my RAM acting up so I tried Windows Memory Diagnostic and it said was a hardware fault detected.


Did some troubleshooting and I tried disabling XMP and now I don't get any faulty hardware detected in Windows Memory Diagnostic tool. Also the PC haven't BSOD since then.

 

I looked at Gigabytes website and it looks like I have the latest version available of BIOS. Is it a BIOS-issue or is it that my RAM are too slow? I tried setting the speed manually on my RAM in BIOS but the PC wouldn't boot after. Not sure if I did it wrong, I just changed it back to normal and now it's back to running on 2133Mhz. Am I missing something here?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, mkN1G said:

As stated in the title.

I bought the motheboard and a i7 12700k. Installed everything and the PC boots just fine. I also installed W11.

RAM - Corsair Vengeance 4x8GB 3000Mhz.

 

However, RAM is running at 2133Mhz in Windows. If I enable XMP my PC won't boot, or if it does it sometimes bluescreens, turns off by itself. I also tried to run Escape from Tarkov and it either froze on me or crashed.

I thought it was my RAM acting up so I tried Windows Memory Diagnostic and it said was a hardware fault detected.


Did some troubleshooting and I tried disabling XMP and now I don't get any faulty hardware detected in Windows Memory Diagnostic tool. Also the PC haven't BSOD since then.

 

I looked at Gigabytes website and it looks like I have the latest version available of BIOS. Is it a BIOS-issue or is it that my RAM are too slow? I tried setting the speed manually on my RAM in BIOS but the PC wouldn't boot after. Not sure if I did it wrong, I just changed it back to normal and now it's back to running on 2133Mhz. Am I missing something here?

Did you buy all the RAM DIMMs in a single bundle ? XMP stability is usually only confirmed for the DIMMs in the package so adding two additional ones of the same speed might already be an unstable OC in that configuration.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Dreckssackblase said:

Did you buy all the RAM DIMMs in a single bundle ? XMP stability is usually only confirmed for the DIMMs in the package so adding two additional ones of the same speed might already be an unstable OC in that configuration.

 I did not buy them in the same bundle. I bought 2 of them in march 2020. I can't remember when I bought the other 2. Could that really be the issue?

I am pretty sure I had XMP enabled on my old motherboard.

 

Do I need to buy 2x16GB instead?

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, mkN1G said:

 I did not buy them in the same bundle. I bought 2 of them in march 2020. I can't remember when I bought the other 2. Could that really be the issue?

I am pretty sure I had XMP enabled on my old motherboard.

 

Do I need to buy 2x16GB instead?

Those would be verified to work,

but usually you can pretty easiliy get a stable RAM OC a bit below the rated spec when using 4 Sticks. I would suggest to try a Manual OC at around 2600 ~ 2888 at 1,35v first and see if thats stable. 

Link to comment
Share on other sites

Link to post
Share on other sites

18 minutes ago, Dreckssackblase said:

Those would be verified to work,

but usually you can pretty easiliy get a stable RAM OC a bit below the rated spec when using 4 Sticks. I would suggest to try a Manual OC at around 2600 ~ 2888 at 1,35v first and see if thats stable. 

This is some unexplored territory to me. Is this safe to do? Will I get the same issue again like it's not booting if it's "too much"?

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, mkN1G said:

This is some unexplored territory to me. Is this safe to do? Will I get the same issue again like it's not booting if it's "too much"?

If those Values are still 'too much' as you put it, you could expect the same issues you have gotten before.

But it is safe to do so in the sense of it will not damage any hardware.

Link to comment
Share on other sites

Link to post
Share on other sites

18 hours ago, Dreckssackblase said:

If those Values are still 'too much' as you put it, you could expect the same issues you have gotten before.

But it is safe to do so in the sense of it will not damage any hardware.

I think I fixed it now. Changed the speed to 3000Mhz in BIOS and adjusted the voltage to 1,36V. In the link I sent above it says my RAM needs 1,35V.

 

Now it shows up in Windows as 3000Mhz. The PC booted up normal too. Hopefully no BSOD or any other errors will come. Thank you @Dreckssackblase!

Link to comment
Share on other sites

Link to post
Share on other sites

@Dreckssackblase Okey so unfortunately I jinxed it. I just got a BSOD when watching twitch. It said "reference by pointer". Now I am wondering, did I set the speed too high or is it the voltage?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×