Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Just a PC Question.

Hey PC lovers, 

I just want to say i am a big fan you linus tech tips and have learned alot from his videos.

I just have a worring question, i just built my pc and it went well. however the think thats bugging me is when i put the cpu with in the motherboard and put a lot of pressure when closing the magnesium to secure the intel cpu and so i got worried and then i opened the magnesium to see the cpu. where i saw the eges of the intel cpu go a little dent. The pc works fine, but i just wanted to know if the is normal due the the pressure the closing magnesium need to allow the intel cpu to be attached to the motehrboard. 

Link to comment
Share on other sites

Link to post
Share on other sites

There shouldn't be a dent but it may take a bit of pressure to close the retention arm. The bracket normally slides with a bit of friction over the cpu. 

Make sure that the cpu is in the socket before closing the bracket but wiggling the cpu a bit in place. There should be no pressure needed to insert the cpu. 

 

Moved to CPUs, Motherboards, and Memory.

If you ever need help with a build, read the following before posting: http://linustechtips.com/main/topic/3061-build-plan-thread-recommendations-please-read-before-posting/
Also, make sure to quote a post or tag a member when replying or else they won't get a notification that you replied to them.

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, WoodenMarker said:

There shouldn't be a dent but it may take a bit of pressure to close the retention arm. The bracket normally slides with a bit of friction over the cpu. 

Make sure that the cpu is in the socket before closing the bracket but wiggling the cpu a bit in place. There should be no pressure needed to insert the cpu. 

 

Moved to CPUs, Motherboards, and Memory.

So your saying that shit is not meant to happen: 

Screenshot_20211202-184506_Chrome.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, I like Computers said:

So your saying that shit is not meant to happen:

is normal.

CPU: i7-8700k 5GHz@1.25v | MoBo: Asus ROG Maximus X Formula | RAM: G.Skill F4-3600C15D-16GTZ @4000CL17GPU: RTX 2080Ti | PSU: Evga Supernova G2 750w | 

Case: Lian Li 011D XL | Storage: Samsung 970 EVO M.2 NVMe 500GB, Crucial MX500 500GB | Soundcard: Soundblaster ZXR | Mouse: Razer Viper Mini | Keyboard: Razer Huntsman TE Monitor: DELL AW2521H @360Hz |

 

Link to comment
Share on other sites

Link to post
Share on other sites

56 minutes ago, DarkSmith2 said:

is normal.

Thanks, guys I really got worried!!!!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×