Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Weird behavior with USB Switch

SuperFryn
 Share

Go to solution Solved by SuperFryn,

Hello All,

I find out the problem, after many many many different things i have tried.

Found out if was the USB cable from the Switch that was causing the issue, used another cable from the box to my PC and it's resolved.


Weirdest issue but hey, glad it's solved !

Thanks All

Good Day Everyone.


I am not new to LTT but new to the forum itself.

I come to you because i have a very strange issue, that i don't know how to fix.


For the short story, i had my setup below 

5800X Stock speed with a Galahad 360 AIO

Radeon RX 6800 Reference

16GB of DDR4 3600MHZ Crucial Ballistix RGB

512GB of Samsung SATA SSD

2TB of Western Digital HDD

750W Corsair TX750M

Lian Li O11 Dynamic.

 

My pc was running fine and 0 issues to be reported. During black friday i got a deal on a NVME SSD from WD BLACK, a SN 750 SE with 1TB

So i decided to reinstall windows on the new SSD and format the old one.

Things done, i reinstall my PC and all my games and all seems well.

 

However, as soon as i reinstalled Halo Infinite MP, i have been having strange issues, when i play with my mouse an keyboard, i have HUGE input delay with the keystrokes, sometimes it doesn't recognize a keystroke, sometimes a key get stuck so my character keeps moving left for ever even without me touching the keyboard.

I have my keyboard and mouse plugged into a USB Switch from Sabrent : https://www.sabrent.com/product/USB-USS4/usb-2-0-sharing-switch-up-to-4-computers-and-peripherals/ 

I use this because i have my setup for my mouse and keyboard shared between my work laptop and my gaming PC. 

 

It used to work just fine before i reinstalled windows but now no more.

So far what i discovered :

 

-Keyboard works just fine if plugged directly into the USB port in the PC

-Xbox wired controller works also just fine

-The switch isn't powered on if i use another USB port on the PC, it works only with one or two

-This issue is ONLY with Halo, all other games are having 0 issues

-The behavior is impacting the whole PC as long as Halo is running, so when halo is in the background i have the same issue per example while typing in a word document

-Every single driver has been checked and updated correctly

 

For me it's something to do with the USB Switch, but why does it only impact Halo???
I am a bit lost here, if anyone has a suggestions, i have all ears!

 

Thanks everyone

Have a good day !

 

SF

Link to comment
Share on other sites

Link to post
Share on other sites

Hello All,

I find out the problem, after many many many different things i have tried.

Found out if was the USB cable from the Switch that was causing the issue, used another cable from the box to my PC and it's resolved.


Weirdest issue but hey, glad it's solved !

Thanks All

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×