Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Various stability like problems in-game

I have encountered some terrible problems while gaming that appeared out of nowhere. As far as it goes this applies to most of my games but the Witcher 3 seems to be the worst offender. 

Specs:
MSI B450M MORTAR MAX

Ryzen 5 2600 (stock)

2x16GB DDR4 HyperX Fury 3600MHz (3200MHz)

Kingston A400 SATA SSD (boot)

Seagate Barracuda 2TB HD (game library)
BeQuiet System Power 8 600W PSU

 

At first I thought that the Witcher 3 game engine has gone haywire and somehow corrupted itself, yet this was not the case as most other games were encountering problems that I am about to explain.

PROBLEMS:

 

First main problems that started with dialogue, long loading times while interacting with NPC's, long loading times while choosing dialogues. This completely broke the emersion of the game. Soon enough the game started having texture loading issues. As soon as I loaded up a save file most textures were not loaded in, most characters looked like they were pulled straight from Witcher 1. At times even full assets wouldn't load allowing me to fully go through them. Certain animations stopped breaking, like with Roach, when you were riding him, there was no animation, just a static model of him going in the pointed direction. Also the game sometimes freezes in one frame yet the game is still going in the background. Basically the game was absolutely fucked. To preface this I'm going to point out what could have caused these issues.

 

1'st possibility: Like a good 10 hours before there problems appeared I had messed with my Ryzen Master program. I tried to dabble in OC'ing after looking at a few tutorials. Played around for a bit, setup a profile, realized that the OC doesn't net me anything since I am GPU bottlenecked, and so I try to reset to the default profile that comes with the program. The default profile that comes with Ryzen Master usually doesn't boost all the time, for my system, on idle RM would keep the clocks at around 1.5GHz. Yet after I had "reset" to the defaults my CPU was constantly boosting to 3.8GHz all core. I realized that something was wrong, yet I didn't worry that much since my performance in-game was still the same. After a bit I try to remedy this by uninstalling RM to basically get rid of all of the settings that may be hidden away, yet to no avail. Still stuck with a 3.8GHz all core. Tried resetting to BIOS optimized defaults yet again, nothing. So I gave up and didn't really bother with it.

 

2'nd possibility: A week or so before this I had realized that my RAM was not running at the speed I had set it to (3200MHz with some tight timings, this was done with MSI Memory Try It). I go into the BIOS and just loosen the timings. I highly doubt that this could be the root of the problem as till today the RAM is still running at the speed I had set, also I have ran a MemTest86 test, which finished with no errors. Anecdotally I had tried to reseat the RAM and that seems to help for a few minutes in-game, although this seems the case with each fresh reboot of the game.

 

What have I done to fix this: 

DDU uninstalled the GPU drivers and installed fresh new ones, reseated the ram and tweaked it's settings, reinstalled a fresh copy of Windows 10, tried to play around with the game settings (doesn't have any impact as the game runs at a solid 75 to 60 fps all the time). 

I need serious help, as this is an issue that is affecting all of my games, and yet somehow a fresh Windows 10 reinstall hasn't helped one bit.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×