Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

100% CPU & GPU Usage while playing apex

Hi guys,

 

I love to play apex, so that’s what I do the most. What freaks me out is that when I load up apex legends, my gpu and cpu go to 100%. A month ago this was at a normal: GPU 50-80% & CPU 50-60%.

 

Does anyone know how to fix this issue?

 

specs:

 

i5-4460

RX 480

16gb ddr3 1600mhz ram

sharkoon tg4 case

(I noticed that the temps are bad to, but I don’t know if that’s really the issue.)

Link to post
Share on other sites

I would recommend new thermal paste but what is your avg frame rate and what are the temps

Link to post
Share on other sites
1 minute ago, Surestgarlic2 said:

I would recommend new thermal paste but what is your avg frame rate and what are the temps

Average framerate is 115 fps and the temps are for my gpu around 80 degrees celsius and for the cpu 70

Link to post
Share on other sites
Just now, Tenty said:

Average framerate is 115 fps and the temps are for my gpu around 80 degrees celsius and for the cpu 70

that's not bad I honestly wouldn't do anything my CPU and GPU usage is at 100% in CSGO at 40fps I would be lucky to be able to launch apex

Link to post
Share on other sites
14 minutes ago, Surestgarlic2 said:

that's not bad I honestly wouldn't do anything my CPU and GPU usage is at 100% in CSGO at 40fps I would be lucky to be able to launch apex

Dude as i already said, it wasn't like that before. Don't give dumb advice please

Link to post
Share on other sites
Just now, Tenty said:

Dude as i already said, it wasn't like that before. Don't give dumb advice please

just re apply thermal paste if your that worried

Link to post
Share on other sites
Just now, Surestgarlic2 said:

just re apply thermal paste if your that worried

Dude how tf would that change my gpu usage.. u clearly know nothing about pcs

Link to post
Share on other sites

HI Tenty,

 

It is indeed weird that this changed, has there been a patch for the game that now adresses the system resources differently perhaps?

Has your FPS gone up too? might be that the patch utilizes more resources now and so you are getting better results.

 

I see your hardware is not the newest either, so I would expect utilization to be high in general.

 

Otherwise I would run a malware / anti-virus scan, it is not uncommon for malicious software to hide behind a known system load.

 

Hope this helps

 

Link to post
Share on other sites
34 minutes ago, aurrorax said:

HI Tenty,

 

It is indeed weird that this changed, has there been a patch for the game that now adresses the system resources differently perhaps?

Has your FPS gone up too? might be that the patch utilizes more resources now and so you are getting better results.

 

I see your hardware is not the newest either, so I would expect utilization to be high in general.

 

Otherwise I would run a malware / anti-virus scan, it is not uncommon for malicious software to hide behind a known system load.

 

Hope this helps

 

Hi thanks for answering, no my fps has been the same. And yes there might was a patch as it began after a big update. Can I run the scan trough Windows Defender?

Link to post
Share on other sites
1 hour ago, Tenty said:

Hi thanks for answering, no my fps has been the same. And yes there might was a patch as it began after a big update. Can I run the scan trough Windows Defender?

Windows defender is a great start, make sure to use the full scan option, this will probably take a while.

 

otherwise download a trial of malwarebytes as an extra option

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×