Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

GTX 970 wont post

So i helped my buddy build a pc, his specs are

i5 4460

12 gb of DDR3

Some dell mobo that came in his pc

GTX 970

Aresgame 500W psu

 

The MOBO, CPU and ram all came with the pc. So we recently switched his old GPU for a 1650 with GDDR6, and it worked flawlessly. Then we decided to return the 1650 because we bought it for way to much money and we got the GTX 970 to replace it. BUT, when we put in this 970 it would not post at all. I tried it in 2 different pcs and it worked in both, but those pcs had better specs. I tried it on my rig and it booted up just fine, i then tried it on my brothers rig with worse specs and it booted up after like 2 minutes of not posting. Both of these pcs have DDR4 and a fairly new MOBO compared to my friends build. For a temporary solution, i have given him a GTX 1050 and it works just fine, but as soon as i swap that out for the 970, it doesn't post. I have tried resetting CMOS but do you guys have any other suggestions? Im just so confused because his mobo can handle a much newer gpu (the 1650) just fine and it can also handle a 720 (which was his first gpu) just fine even though a 720 is much older and a 1650 is much newer.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×