Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

In a bit of a pickle, New Build cannot connect to screen, help please?

Tedwyn
 Share

I built my PC last night and wanted to spend today setting it all up, The components are running fine, but when I try to connect the PC to my screen the screen doesn't register the HDMI or the VGA, I have tried them both separately in different ports, I know both cables work as I used them for my laptop and my Xbox 360 and I know there is nothing wrong with my screen as its working now as I type this, I have no idea how to the rectify this, somebody help please?

PC Enthusiast, Devourer of biscuits

Link to comment
Share on other sites

Link to post
Share on other sites

make sure thaf if you are using a dedicated graphics card that the monitor is connected to the ports on the card, not the ports on the motherboard

 

if that doesn't  work try taking the graphics card out and using the connections on the motherboard and see if anything displays

Desktop - Corsair 300r i7 4770k H100i MSI 780ti 16GB Vengeance Pro 2400mhz Crucial MX100 512gb Samsung Evo 250gb 2 TB WD Green, AOC Q2770PQU 1440p 27" monitor Laptop Clevo W110er - 11.6" 768p, i5 3230m, 650m GT 2gb, OCZ vertex 4 256gb,  4gb ram, Server: Fractal Define Mini, MSI Z78-G43, Intel G3220, 8GB Corsair Vengeance, 4x 3tb WD Reds in Raid 10, Phone Oppo Reno 10x 256gb , Camera Sony A7iii

Link to comment
Share on other sites

Link to post
Share on other sites

try running of of the intergrated one to see where is the problem

RIG-Processor: Intel core i7 3770k @4.4GHz,Mobo: MSI Z77-G43,GPU:Gigabyte GTX 770, RAM:16 GB G-skill sniper f3,SSD: Corsair Force f3 240gb,HDD: Seagate baracuda 1TB,Cooler:CM Hyper 212 evo, Case: Sharkoon T28 Blue

Peripherals- Monitor: Samsung S24B300, Keyboard: Razer Blackwidow, Mouse: Razer Abyssus, Headphones: Razer Megalodon, Mousepad: Razer Goliathus Alpha, Webcam: Logitech C270,Pad:Logitech F710, Sp: Philips generic ones

#KILLEDMYWIFE #MAKEBOMBS

Link to comment
Share on other sites

Link to post
Share on other sites

I've tried both the ports on the GPU and the Motherboard starting with the GPU first

PC Enthusiast, Devourer of biscuits

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×