Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hi, up until yesterday I was perfectly fine with my system (listed below) doing stuff as always. While I was playing a game system just shut down completely no sign of life even on/off button led on mobo (which stays lit while the system is turned off) was gone. I tried to restart nothing happened. I did some googling and tried stuff like unplugging psu and all the cables from the mobo, clearing cmos, taking off the cmos battery, waiting for a while and such but no result.

 

After all these, I am stuck in a state that just clear cmos button blinking nothing else. As a last resort, I tried q flash plus thing. I took off everything from the mobo all the cables, cpu, gpu, ram, ssd, etc. 
Just plugged the 24pin and 8pin power cable and plugged a USB on the white USB port on rear IO (as instructed in manual with the right file name and USB format etc. btw I downloaded the latest bios version which is currently F30). When I turned the power on, the same thing just blinking clear cmos button and q flash plus button also does not do anything. 

 

It would be perfect if someone can helped in desperation right now.
 

1kVA online UPS
x570 Aorus Master (at bios version F11 at the time of failure)
Ryzen 3950x
Nvidia Quadro 4000 ( yes I do play games on quadro)
G.skill 64GB 3600MHz
Corsair h150i
Corsair hx850i
Corsair fans 4x120mm
Samsung Evo 970

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×