Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

MY LAPTOP IS BEING A POTATO HELP

Hey, my ROG Zephyrus M GU502 with a Nvidia 1660ti, i7 9750H is getting unplayable frame rates on FORTNITE(~30 fps) (low settings) and other non-intensive titles. 

 

I've updated the game ready drivers and theres no change. I can't play any game on even low settings even though im supposed to be able to!

 

I checked benchmark numbers for the laptop version 1660ti and i should be getting 3 times the frame rates im getting!

 

I've tried everything from making sure my laptop is on high performance mode and making sure it's cooled properly but nothing seems to get more than ~5-10 fps increase.

 

Please help me! This is my only 'gaming' machine and in this crazy quarantine here in India i dont have anything else to do  :(

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Do you know if your laptop has a setting that allows it to run off the integrated graphics instead of the dedicated? If so check that and make sure it’s not set to running off of integrated.

I am far from an expert in this so please correct me if I’m wrong.

Quote or tag me so I can see your response

 

PSU Tier List

Motherboard Tier List

Graphics Card Cooling Tier List

CPU Cooler Tier List

SSD Tier List

 

PARROT GANG

Mentioned in 7/10/20 WAN Show

Mentioned in 7/15/20 Techlinked

Mentioned in 7/17/20 Techlinked

Mentioned in 7/31/20 WAN Show

Mentioned in 7/31/20 Techlinked

Mentioned in 8/3/20 Techlinked

Mentioned twice in 8/5/20 Techlinked

Mentioned twice in 8/7/20 Techlinked

Mentioned in 8/12/20 Techlinked

Mentioned in 8/19/20 Techlinked

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, zeusthemoose said:

Do you know if your laptop has a setting that allows it to run off the integrated graphics instead of the dedicated? If so check that and make sure it’s not set to running off of integrated.

Yeah, I run it off my dedicated graphics and it shows that the dedicated graphics are being used but no change :(

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, dragondonut123 said:

Yeah, I run it off my dedicated graphics and it shows that the dedicated graphics are being used but no change :(

IDK if fortnite has it, but try checking the settings to make sure that the game itself is running on dedicated. Is the laptop or game on a power saving mode? If it is try turning that off.

I am far from an expert in this so please correct me if I’m wrong.

Quote or tag me so I can see your response

 

PSU Tier List

Motherboard Tier List

Graphics Card Cooling Tier List

CPU Cooler Tier List

SSD Tier List

 

PARROT GANG

Mentioned in 7/10/20 WAN Show

Mentioned in 7/15/20 Techlinked

Mentioned in 7/17/20 Techlinked

Mentioned in 7/31/20 WAN Show

Mentioned in 7/31/20 Techlinked

Mentioned in 8/3/20 Techlinked

Mentioned twice in 8/5/20 Techlinked

Mentioned twice in 8/7/20 Techlinked

Mentioned in 8/12/20 Techlinked

Mentioned in 8/19/20 Techlinked

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, zeusthemoose said:

IDK if fortnite has it, but try checking the settings to make sure that the game itself is running on dedicated. Is the laptop or game on a power saving mode? If it is try turning that off.

The games are running on dedicated graphics (atleast thats what they say) and my laptop is plugged in and not in power saving mode :(

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×