Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Corsair H100i RGB Platinum - Fan Speed Problems

Hey all, 

 

Bought a new Corsair H100i RGB Platinum AIO cooler on Amazon the other day and installed it today. Was having a few problems with high very fan speed but managed to rectify it. Read the log of events below if you're interested or encountering similar problems.

 

Plugged it in as per instruction manual. Both fans' power and RGB into the splitters coming out of the Pump, and the USB going to a USB header on the motherboard.

Turned on the PC, all was fine until desktop, when both fans ramped right up to 100% and wouldn't go down. In Ryzen Master, CPU was chilly at about 22 degrees.

Opened Corsair's iCUE software (I also have a Strafe Keyboard and Void Headset) and on all of the fan control settings, even quiet, it was super noisy, and the RGB was just not sticking to the setting I wanted either.

 

WILD GOOSE CHASE TIME (DO NOT FOLLOW THESE STEPS)

Found out by unplugging individual fans from the splitter that the one marked '1' was by far the highest RPM, so got a splitter out and tried to run both off of the non marked plug. Things were okay but not quiet at all, maybe at 1600RPM instead of the 2000+RPM i had from Plug '1'.

Messed around for ages with fan curves trying to get it as silent as possible, but it still sounded like a vacuum cleaner even at the quietest I got it.

Plugged in the both fans into 1 and unmarked again as per instructions and messed around with the ASUS QFan control in the UEFI. Didn't solve anything. 

At this point I was so upset with it and thought about sending it back and putting my old CoolerMaster pump-noise-a-tronic 3000 back on. 

At my wits end, disabled iCUE from Startup Programs. Restarted my PC and it was running really quiet, started iCUE and boom it comes in 100% again. Problem is with iCUE then.

Went back into iCUE and was looking through the settings for ages trying to set pump to Extreme, but fans to minimum RPM to try and offset the noise.

Tried reinstalling iCUE, and still nothing.

And so, the final thing I could think of trying....

THE FIX (DO FOLLOW THIS STEP!): Checked the Firmware in Settings in iCUE. iCUE told me that the firmware was up to date. Then spotted that I could force a firmware update, what is there to lose right?

Everything was fixed, just like that. Fans are now running on 500RPM or lower 90% of the time and cooling performance is great.

So basically, even if it tells you the firmware is up to date, never trust it and update it yourself.

 

TLDR: Update your firmware in iCUE if you have problems with fans running 100%

 

Thanks for reading

 

Rhys

 

 

CURRENT: intel i9-10900K ASUS ROG Maximus XII Hero ROG Strix RTX 3090 32GB 3600MHz Corsair Vengeance RGB Pro RM1000i Lian Li O11-Dynamic

OFFICE: intel i5-3570K ASUS Z77 mITX EVGA GTX 970 SC 16GB 1600MHz Corsair Vengeance LP Silverstone SFX PSU Fractal Design Node 202

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×