Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

GPU not activating in games

corbax
 Share

Hello guys. So my problem is that my graphic card dose not activate when I enter a game (League of Legends). CPU usage jumps to 100%, Intel's integrated graphics to about 10% and my GPU is on 2-3%. If I try deactivating intels GPU in device manager CPU usage drops and GPU usage jumps a bit but my FPS is about 15 witch is much lower than before. I tried setting GPU as primary device in nVidia control panel but only thing that changed is that graphics are a bit sharper even though I set it for performance. Can you please help me solve my issue. I tried reinstalling GPU divers but no help. My laptop specs are i5 7300HQ, 8gb RAM, GTX 1050ti. 

Also once I got BSOD for faulty hardware corrupt. I checked everything for that BSOD and everything was fine (thinking it was because I have installed Deamon tools). I don't know if that BSOD has to do something with this but just saying maybe it helps.

Thanks for help.

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, corbax said:

Hello guys. So my problem is that my graphic card dose not activate when I enter a game (League of Legends). CPU usage jumps to 100%, Intel's integrated graphics to about 10% and my GPU is on 2-3%. If I try deactivating intels GPU in device manager CPU usage drops and GPU usage jumps a bit but my FPS is about 15 witch is much lower than before. I tried setting GPU as primary device in nVidia control panel but only thing that changed is that graphics are a bit sharper even though I set it for performance. Can you please help me solve my issue. I tried reinstalling GPU divers but no help. My laptop specs are i5 7300HQ, 8gb RAM, GTX 1050ti. 

Also once I got BSOD for faulty hardware corrupt. I checked everything for that BSOD and everything was fine (thinking it was because I have installed Deamon tools). I don't know if that BSOD has to do something with this but just saying maybe it helps.

Thanks for help.

You can maybe try disabling igpu in bios , if there is option for that, not sure what bios you got

   @Whiro tag or quote will do the trick 
i5 3570K @ 4.7Ghz  |  AsRock Fatal1ty Z77 Performance  |  Corsair Vengeance 16GB 1600MHz  |  ASUS Strix GTX 970 OC  |  Phanteks P400S TG  (mesh panel) |  EVGA 500W1  |  Storage: Corsair 60GB SSD (boot), Gigabyte 120GB SSD, WD 2Tb HDD | Cooling: Custom loop

                EKWB EK-XRES 140 Revo D5 RGB PWM

                EKWB EK Supremacy Evo , naked die

                EKWB EK Thermosphere 

                EKWB EK CoolStream PE 360

                EKWB EK Coolstream SE 120

                EKWB EK Vardar 120s  x6

                EKWB EK STC Classic 10/16  x10

                EKWB EK DuraClear Tubing 16/10

                EKWB EK CryoFuel Acid Green


Laptop: Gigabyte G5-KC | i5 10500H | RTX 3060

                                          WHIRO

         THE FIRST OF DEATH AND DARKNESS

 

        He feast on the dead to inherit their power

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Whiro said:

You can maybe try disabling igpu in bios , if there is option for that, not sure what bios you got

I was going to suggest this.  I know in the past it used to be pretty standard to have to disable the onboard graphics in BIOS to get the discrete GPU to work correctly.

Link to comment
Share on other sites

Link to post
Share on other sites

Laptop is HP pavilion something something but my motherboard died and it was change to omen one (i think so cuz on boot it shows omen logo) but I have less than a sec to enter BIOS because that part of boot passes so quick i am unable to enter it.

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, corbax said:

Laptop is HP pavilion something something but my motherboard died and it was change to omen one (i think so cuz on boot it shows omen logo) but I have less than a sec to enter BIOS because that part of boot passes so quick i am unable to enter it.

Would be really helpful to know exactly the mobo number but try to hit continuously F10 really quickly as soon as you push power button. It should enter the bios.

 

14689743-4091-459E-9AF9-7E34A038BD3B.jpeg

   @Whiro tag or quote will do the trick 
i5 3570K @ 4.7Ghz  |  AsRock Fatal1ty Z77 Performance  |  Corsair Vengeance 16GB 1600MHz  |  ASUS Strix GTX 970 OC  |  Phanteks P400S TG  (mesh panel) |  EVGA 500W1  |  Storage: Corsair 60GB SSD (boot), Gigabyte 120GB SSD, WD 2Tb HDD | Cooling: Custom loop

                EKWB EK-XRES 140 Revo D5 RGB PWM

                EKWB EK Supremacy Evo , naked die

                EKWB EK Thermosphere 

                EKWB EK CoolStream PE 360

                EKWB EK Coolstream SE 120

                EKWB EK Vardar 120s  x6

                EKWB EK STC Classic 10/16  x10

                EKWB EK DuraClear Tubing 16/10

                EKWB EK CryoFuel Acid Green


Laptop: Gigabyte G5-KC | i5 10500H | RTX 3060

                                          WHIRO

         THE FIRST OF DEATH AND DARKNESS

 

        He feast on the dead to inherit their power

Link to comment
Share on other sites

Link to post
Share on other sites

So I managed to enter BIOS but I think that there is no option for disabling igpu

81774562_1005670739807161_8055502890711646208_n.jpg

81793554_2709486612467556_3138597061503483904_n.jpg

82226672_608883463239315_2445967519836536832_n.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, corbax said:

 

So I managed to enter BIOS but I think that there is no option for disabling igpu

 

Go to display settings -> graphics settings (red text 3/4 of the way down the page). Afterwards browsed for the .exe's of the games, and select the option to use the high performance graphics for each game .exe. For some reason, windows and steam listen to this particular option and none of the others. All games, should now use dedicated gpu

   @Whiro tag or quote will do the trick 
i5 3570K @ 4.7Ghz  |  AsRock Fatal1ty Z77 Performance  |  Corsair Vengeance 16GB 1600MHz  |  ASUS Strix GTX 970 OC  |  Phanteks P400S TG  (mesh panel) |  EVGA 500W1  |  Storage: Corsair 60GB SSD (boot), Gigabyte 120GB SSD, WD 2Tb HDD | Cooling: Custom loop

                EKWB EK-XRES 140 Revo D5 RGB PWM

                EKWB EK Supremacy Evo , naked die

                EKWB EK Thermosphere 

                EKWB EK CoolStream PE 360

                EKWB EK Coolstream SE 120

                EKWB EK Vardar 120s  x6

                EKWB EK STC Classic 10/16  x10

                EKWB EK DuraClear Tubing 16/10

                EKWB EK CryoFuel Acid Green


Laptop: Gigabyte G5-KC | i5 10500H | RTX 3060

                                          WHIRO

         THE FIRST OF DEATH AND DARKNESS

 

        He feast on the dead to inherit their power

Link to comment
Share on other sites

Link to post
Share on other sites

Already did that before asking here for help

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×