Jump to content

RX 480 went bad?

King_Richard

Hi there, newbie in the forum here.

Been facing a problem with my Sapphire RX480 8Gb OC Edition. It supposedly is powerful enough to run some games, but been finding lots of stuttering in some, which leaves me baffled. In Hitman, Nier:Automata and Shadow of Tomb Raider, the first two games i run in high settings and it struggles a bit with some frame drops, but just some periodic hickups. In SoTR it stutters in most playable scenes, getting worse through the end of the game. The start menu is slow as hell. Just as experience, tried it in low settings and even there i get a bit of stuttering too.

This surprises me because in a lower spec system i have, those games run smoothly (i5-3330, 8Gb DDR3, MSI 1050Ti LP).

Tried with older and newer drivers, getting worst results with Adrenaline 19.3.1. Even Catalyst series gives me problems (but better than newer one).

Heaven 4.0 reports a score of 1199 (FPS:47.6, Min:26.2, Max:92.4) with Extreme option, DX11 and windowed 1600x900 8xAA. Done other test to compare with one guy in Reddit and got a score of 1354 with the same options as him, while his score was 1913 (2 years ago test). Funny thing is that Heaven recognizes my RX480 as if has only 4Gb, while CPU-Z clearly says 8192Mb GDDR5.

The CPU temps never reach 35C and the GPU temps never reach 55C, so it is impossible to be thermal bottleneck.

 

Could it be that the board is struggling for having to drive 5 simultaneous screens that much?

I usually run games in windowed mode, but the problem is present in fullscreen too.

 

System specs in my profile.

 

Any ideas as to why is behaving like this?

Many thanks in advance.

Bench1.jpg

Bench2.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

I had a rx 480 8gb stock cooler(blower) and give it to a friend and had the same problems, solved by raising power limit(%) to max 50% ,because when the rx480 has variable power limit , it will put a stable frequency giving you 0 throttle, when you put it at 0% it will lower your frequency at higher load giving you throttle. I can tell you that there is like half a year since we raise up to 50% (max) and there's 0 problems. 

amd-wattman-overview-100671359-orig.png

Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to comment
Share on other sites

Link to post
Share on other sites

Hello, thanks for the reply and tip.

Done some tests with your suggestion, still no go. Getting absurd low fps on benchmark. The game overall behaves well, but some parts are extremely low (inside cities and in the pause menu). Didn't tried the other two games as this one is the most severe case.

The second pic refers to the settings i found most equilibrated for playing, the last ones are default settings.

 

Am i missing something? My system is well above system minimum specs:

Shadow of the Tomb Raider recommended system requirements

OS: Windows 10 64-bit
CPU: Intel Core i7 4770K, 3.40 Ghz or AMD Ryzen 5 1600, 3.20Ghz
Memory: 16GB RAM
Graphics: Nvidia GTX 1060 6GB or AMD Radeon RX 480 8GB
DirectX: Version 12

 

GameDebate even reports 40fps for Ultra settings and i get 50 on medium ahaha.

 

GPU.jpg

Current.jpg

Medium.jpg

Low.jpg

Compare.jpg

 

EDIT:

Ok, been tweaking and investigating a bit more.

Was able to OC the GPU to a stable 1440MHz and got a few improvements, now the games are smother and with less lag/stutter in the "custom" configuration showed above. Sadly Wattman does not allow more than 1175mV and based on my temps, i could easily reach the 1500MHz mark :D (ASIC Quality reporting 83,4%).

But the point isn't OC, it shouldn't be needed to run those games and the fact is that even with a fairly good OC, still can't play it as it should in "High" settings.

Then, after some investigation, i found what i think is the culprit. Seems like my GPU is running all the time in PCIe x1 1.1 mode! At least is what GPU-Z reports even when maxing GPU usage and it makes sense for the behaviour i'm having. What i don't understand is why it is doing that if the Strix Z370i is a single GPU slot, i'm running the bios with default config and only using the dedicated gpu (system not even detecting the intel one).

 

Do you have any idea as why it is behaving like that and not using the full x16 3.0?

 

PCIe.jpg

Edited by King_Richard
Updated information
Link to comment
Share on other sites

Link to post
Share on other sites

  • 3 weeks later...

Hi everyone.

Posting just to say that i fixed the problem and in case someone stumbles on something similar, here is what worked for me.

In other forum, someone suggested reseating the GPU in place. Well, my GPU is watercooled and with rigid tubbing, so is kind of hard to reseat it. Either way i managed to do it.

First time it was indicating x4 2.0, second time was x8 3.0. Fiddled a bit on the BIOS, turned off the option "Hyper M.2 x16" and it instantly recognized the card with its normal speed.

One note for the people concerned about using a card in x8 vs x16. As some benchmarks already indicated, the difference is not much, so no need to worry about it. Below are my results for each configuration and as you can compare from the previous results, night and day difference.

 

x8 3.0 (same settings than before):

 

x8.jpg

Trbenchx8.jpg

 

x16 3.0 (same settings than before):

 

x16.jpg

Trbenchx16.jpg

 

And just for curiosity, the max this card can give on wattman and with a 600w PSU (temps were stable at 62c, so probably can go higher on afterburner or with different PSU):

 

x16OC.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×