Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Microsoft Family Features

Smiles4Miles
 Share

I recently got an Xbox 1 S for Christmas. My family made our accounts and then we saw something called Family. Not knowing of it restricting my brother and I's access to things on our pc, We made one. Once I realized it had taken away Chrome, I immediately removed myself from my family. I restarted my pc, tried to open google, same thing popped up. "Ask for permission to use: Google Chrome." I tried opening Microsoft Edge (Which I'm currently using right now), And it opened fine. I joined back in the family, and made myself an adult. I changed the year of birth on my account. Nothing has been working and I'm getting fed up. I hate the way Edge is designed, and much prefer Google. It would be nice to have it back. Also, nothing else has been restricted from me from what I know.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×