Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

FFMpeg Problem Need Help

 Share

Hello,

After installing FFMpeg and creating the right path I can't seem to get it to work. As it stands now any FFMpeg command I enter in cmd gives back the message "'ffmpeg' is not recognized as an internal or external command, operable program or batch file". Before this I had gotten it to recognize FFMpeg commands but any video I tried to work with wouldn't be recognized even though they were in the bin folder. In an attempt to fix this I reinstalled FFMpeg and now as you can see above I'm even further back. I know I have a video converting software that uses FFMpeg but that shouldn't be a problem I think. Any idea what I'm doing wrong? Any help would be greatly appreciated. I'm using windows 10 and FFMpeg 4.1.

Thanks,

Zach

Link to comment
Share on other sites

Link to post
Share on other sites

if you want to run ffmpeg, you should copy the entire path of the executable, or place the ffmpeg folder in your path variable :) 

https://video.stackexchange.com/questions/20495/how-do-i-set-up-and-use-ffmpeg-in-windows

Dutch Talk Thread

Unofficial LMG Social Media Accounts Website

Desktop Rig:

CPU: i7-4790K Cooler: Cooler Master Hyper 212 EVO Motherboard: MSI Z97 U3+ RAM: 4x4 GB DDR3 1600MHz GPU: MSI GTX 1070 Ti 8G Case: Corsair 230T Windowed Orange SSD: Crucial BX100 250 Gb PSU: Cooler Master G450M HDD: WD 1 TB Generic

Laptops: Macbook Air 2012 11" baseline (i5-3317U @ 1.7 Ghz) upgraded with a Samsung 850 evo 250 GB SSD

HP Zbook Studio G5 (i7-8750H, 32 GB DDR4 2666MHz, Samsung PM981 512 GB, 970 EVO 1TB, Nvidia Quadro P1000)

Link to comment
Share on other sites

Link to post
Share on other sites

By 'creating the right path' do you mean, you changed the system variable to include the folder that contains your ffmpeg.exe?

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, mikat said:

if you want to run ffmpeg, you should copy the entire path of the executable, or place the ffmpeg folder in your path variable :) 

https://video.stackexchange.com/questions/20495/how-do-i-set-up-and-use-ffmpeg-in-windows

Thanks for the response, that seemed to get ffmpeg and its related executables to work. However the program doesn't recognize any of the videos I try to run. I have the videos in the same folder as FFMpeg but it won't work.

 

This is what it gives me

 

C:\Users\My Name>ffplay -i day.mp4
ffplay version 4.1 Copyright (c) 2003-2018 the FFmpeg developers
  built with gcc 8.2.1 (GCC) 20181017
  configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
day.mp4: No such file or directory 0KB vq=    0KB sq=    0B f=0/0

 

Any idea what could be causing this?

Thanks again,

Zach

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, Granular said:

By 'creating the right path' do you mean, you changed the system variable to include the folder that contains your ffmpeg.exe?

Thanks for the response, that seemed to get FFMpeg and its related executables to work. However the program doesn't recognize any of the videos I try to run. I have the videos in the same folder as FFMpeg but it won't work.

 

This is what it gives me

 

C:\Users\My Name>ffplay -i day.mp4
ffplay version 4.1 Copyright (c) 2003-2018 the FFmpeg developers
  built with gcc 8.2.1 (GCC) 20181017
  configuration: --enable-gpl --enable-version3 --enable-sdl2 --enable-fontconfig --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libtheora --enable-libtwolame --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libzimg --enable-lzma --enable-zlib --enable-gmp --enable-libvidstab --enable-libvorbis --enable-libvo-amrwbenc --enable-libmysofa --enable-libspeex --enable-libxvid --enable-libaom --enable-libmfx --enable-amf --enable-ffnvcodec --enable-cuvid --enable-d3d11va --enable-nvenc --enable-nvdec --enable-dxva2 --enable-avisynth
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100
day.mp4: No such file or directory 0KB vq=    0KB sq=    0B f=0/0

 

Any idea what could be causing this?

Thanks again,

Zach

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, Zach Phillamps said:

I have the videos in the same folder as FFMpeg but it won't work.

This is what it gives me

C:\Users\My Name>ffplay -i day.mp4

When you call a command, you are supposed to specify file location relative to the directory you're in, not relative to where the program is. The prompt shows you are in C:\Users\Your Name.

C:\Users\Your Name>ffplay -i day.mp4 is instructing ffplay to open C:\Users\Your Name\day.mp4, which I'm guessing is not where you keep the file.

You need to either use the 'cd' command to change your working directory to the directory containing the video file ( like C:\Users\Your Name\Videos or wherever it is you keep it) and then run ffplay -i day.mp4

Or stay where you are and specify a full (not relative) path for the input file with ffplay -i C:\Users\Your Name\Videos\day.mp4

Link to comment
Share on other sites

Link to post
Share on other sites

21 hours ago, Granular said:

When you call a command, you are supposed to specify file location relative to the directory you're in, not relative to where the program is. The prompt shows you are in C:\Users\Your Name.

C:\Users\Your Name>ffplay -i day.mp4 is instructing ffplay to open C:\Users\Your Name\day.mp4, which I'm guessing is not where you keep the file.

You need to either use the 'cd' command to change your working directory to the directory containing the video file ( like C:\Users\Your Name\Videos or wherever it is you keep it) and then run ffplay -i day.mp4

Or stay where you are and specify a full (not relative) path for the input file with ffplay -i C:\Users\Your Name\Videos\day.mp4

That got it working, thank you for the help

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×