Jump to content
Sign in to follow this  
Ginge620

Help! H100i pump not working?

Solved the power issue. The Sata connector came out a bit, push it back in and now that the pump and the fans have power :P

Recommended Posts

Posted · Original PosterOP

The cooler worked fine before.

Currently trying to reinstall windows on my SSD in AHCI rather than IDE on the Asus crosshair IV formula.

There is no power coming from the ran connectors on the block and the pump isnt pump and cpu temps go sky high from what i can see in the bios temp monitor.

What can i do?

Also the 3 pin connector that has 1 wire going into it, when i connect this to the CPU header the bios still says no cpu fan connected. Can anyone advise me on what to do?


PC 1 Specs (New) :

Corsair 450D | Intel 4770K | Asus Sabertooth Z97 | 16GB Corsair Vengeance @1600Mhz | Asus STRIX GTX 970 SLI | Samsung 840 EVO 250GB | 2 WD Black 500GB RAID 0 | WD Red 3TB | Corsair AX860 | Corsair H110 | 4 Corsair 140mm LED & 1 120mm Fans

PC 2 Specs (Old) :

Corsair 650D | AMD Phenom II X6 1100T | Asus Crosshair IV Formula | 4GB Corsair XMS3 @1600Mhz | Crossfire HD6970's | Asus Essence STX | OCZ Agility 3 240GB| WD Blue 250GB | WD Green 640GB | XFX850PRO | Corsair H100i

Peripherals :

BenQ 2420T | Packard Bell Viseo 220DX | Corsair K70 | Corsair M65 | Beyerdynamic DT880 Premium | Sennheiser PC360 | Bang & Olufsen Beovox X25's
Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Solved the power issue. The Sata connector came out a bit, push it back in and now that the pump and the fans have power :P


PC 1 Specs (New) :

Corsair 450D | Intel 4770K | Asus Sabertooth Z97 | 16GB Corsair Vengeance @1600Mhz | Asus STRIX GTX 970 SLI | Samsung 840 EVO 250GB | 2 WD Black 500GB RAID 0 | WD Red 3TB | Corsair AX860 | Corsair H110 | 4 Corsair 140mm LED & 1 120mm Fans

PC 2 Specs (Old) :

Corsair 650D | AMD Phenom II X6 1100T | Asus Crosshair IV Formula | 4GB Corsair XMS3 @1600Mhz | Crossfire HD6970's | Asus Essence STX | OCZ Agility 3 240GB| WD Blue 250GB | WD Green 640GB | XFX850PRO | Corsair H100i

Peripherals :

BenQ 2420T | Packard Bell Viseo 220DX | Corsair K70 | Corsair M65 | Beyerdynamic DT880 Premium | Sennheiser PC360 | Bang & Olufsen Beovox X25's
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.


×