Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Tomsta

How to stop Windows trying to automatically repair my 2nd hard drive?

Recommended Posts

Posted · Original PosterOP

This started happening two days ago, Windows prompts to want to repair my drive however it seems to take a long while so i leave it going over night and find that next time i restart it's still asking to scan and repair. Now as this is just my data drive not my OS drive i'm not too fussed if it goes wrong (i've backed up music and photos; everything else can be re-acquired later)

 

Anyone know how to stop Windows trying to repair the drive every time it boots. The drive itself seems fine as i'm able to browse it and game from it fine (my game library is stored on the 2nd drive)

Link to post
Share on other sites

Perhaps try to leave it to scan and repair a second time see if that fixes the issues. If you don't want to/or have already done that then you can try to edit your registry to fix the issue. The video below shows you how to do it. Of course in their case it says autocheck autochk /k C *, but in your case it should be whatever letter the secondary drive has in Windows. So if it's Local Disk D it should say autocheck autochk /k D *.

 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, AndreiArgeanu said:

Perhaps try to leave it to scan and repair a second time see if that fixes the issues. If you don't want to/or have already done that then you can try to edit your registry to fix the issue. The video below shows you how to do it. Of course in their case it says autocheck autochk /k C *, but in your case it should be whatever letter the secondary drive has in Windows. So if it's Local Disk D it should say autocheck autochk /k D *.

 

I did leave it for a 2nd time and same thing (i just tried a restart to make sure)

 

That registry key just had * there which if my coding knowledge serves me well is an indication of a wildcard as in check all drives as it were, just removed it and that seems to have solved it. Hopefully it's Windows being Windows and not an early sign of my 2nd hard drive failing

Link to post
Share on other sites

I think you can if you clear the "dirty bit"

 

https://www.top-password.com/blog/how-to-manually-clear-or-set-dirty-bit-on-windows-volume/#:~:text=To get started%2C open WinHex,on%2C and then click OK.

 

Honestly haven't read through the tutorial I've linked, so sorry if it has garbage. You can try to search for a MS article. I know I have used it back in the XP days. I didn't think I needed a hex editor, I thought it was a chkdsk command. But it's been so long.

 

EDIT: Here is an article from MS:

https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/fsutil-dirty

 

I'd try the MS article first. But if I were you, if you have any important data on that drive, you might want to start backing up.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×