Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
lks_20

MBR2GPT failed - Windows not bootable

Recommended Posts

Posted · Original PosterOP

Hey Guys I think I need some help.

 

I tried to convert my old Legacy Windows installation to an uefi installation with the MBR2GPT.exe tool.

 

I followed a guide which recommended using the command line interface in the troubleshooting menu.

/validate worked for me therefore I tried to convert which gave me this response:

MBR2GPT: Attempting to convert disk 0
MBR2GPT: Retrieving layout of disk
MBR2GPT: Validating layout, disk sector size is: 512 bytes
MBR2GPT: Trying to shrink the system partition
MBR2GPT: Trying to shrink the OS partition
MBR2GPT: Creating the EFI system partition
MBR2GPT: Installing the new boot files
MBR2GPT: Performing the layout conversion
MBR2GPT: Migrating default boot entry
MBR2GPT: Adding recovery boot entry
MBR2GPT: Fixing drive letter mapping
MBR2GPT: Conversion completed successfullyCall WinReReapir to repair WinRE
MBR2GPT: Failed to update ReAgent.xml, please try to  manually disable and enable WinRE.
MBR2GPT: Before the new system can boot properly you need to switch the firmware to boot to UEFI mode!PS 

Everything fine so far except the update of ReAgent.xml

I wasn´t able to enable WinRE manually. The command line said "command not found".

On an other forum I found someone who had exactly the same issues. 

The other users told him to reboot because the conversion was successful. It worked for him therefore I tried the same. 

Now my PC won´t start at all. 

When I select "uefi" in BIOS I the SSD (with windows installation) isn´t even listed. When I select Legacy/CSM I can select my SSD as a boot device. 

But once startet nothing happens except a promt which says something like "insert bootable "device"

 

I have a USB Stick with windows on it. I tried booting and can use its troubleshooting menu. I already used the command line and and was able to disable and enable the WinRE.

I tried using the MBR2GPT tool again and ran the validation command. This time it automatically selects disk-1 instead of disk0.

Running for disk-1 returns an error instantly. 

When I manually select disk 0 It does retrieve the layout and it does validate the layout and it does recognise the right sector size but the validation still fails.

It looks like this:

MBR2GPT: Attempting to validate disk 0
MBR2GPT: Retrieving layout of disk
MBR2GPT: Validating layout, disk sector size is: 512 bytes
Disk layout validation failed for disk 0

I´ve no idea what to do next. Can anyone help me?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×