Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
superspammer76

RX550 2G not displaying

Recommended Posts

Posted · Original PosterOP

Hello so i recently purchased a custom gaming pc and when I got it the lights would turn on and the fans would spin but my screen would read "No Display". When I took the RX550 graphics card out, the pc booted right up and the display worked. Does anyone have an idea what is wrong with the graphics card? Also when the gpu is in the gpu fan spins normally.
The specs on the pc are:

CPU: Intel Quad Core i5-3330 3.0 GHz

GPU: MSI Radeon RX 550 2 GB

RAM: Kingston HyperX Fury 8 GB (2x4) DDR3 1600 MHz

Storage: 500 GB WD Blue HDD

Motherboard: GigaByteGA-H61M-DS2

Power Supply: EVGA 400 WATT

Link to post
Share on other sites
9 minutes ago, superspammer76 said:

Hello so i recently purchased a custom gaming pc and when I got it the lights would turn on and the fans would spin but my screen would read "No Display". When I took the RX550 graphics card out, the pc booted right up and the display worked. Does anyone have an idea what is wrong with the graphics card? Also when the gpu is in the gpu fan spins normally.
The specs on the pc are:

CPU: Intel Quad Core i5-3330 3.0 GHz

GPU: MSI Radeon RX 550 2 GB

RAM: Kingston HyperX Fury 8 GB (2x4) DDR3 1600 MHz

Storage: 500 GB WD Blue HDD

Motherboard: GigaByteGA-H61M-DS2

Power Supply: EVGA 400 WATT

Did you plug your HDMI cable or whatever into the output from the graphics card and not the motherboard?


@BlueScope819 so I can see your post

#MuricaParrotGang

"My name is Legion 'Murica Parrot Gang, for we are many."

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites
Posted · Original PosterOP
Just now, BlueScope819 said:

Did you plug your HDMI cable or whatever into the output from the graphics card and not the motherboard?

yes I did but it still didn't work

Link to post
Share on other sites
Just now, superspammer76 said:

yes I did but it still didn't work

Did you plug in any and all external power connectors for the graphics card, and does the graphics card fan spin?


@BlueScope819 so I can see your post

#MuricaParrotGang

"My name is Legion 'Murica Parrot Gang, for we are many."

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites
Posted · Original PosterOP
Just now, BlueScope819 said:

Did you plug in any and all external power connectors for the graphics card, and does the graphics card fan spin?

yes I did plug in external power connectors and yes the fan does spin

Link to post
Share on other sites
Just now, superspammer76 said:

yes I did plug in external power connectors and yes the fan does spin

Perhaps try a different port from your graphics card? Try installing the graphics card but plugging the HDMI cable or whatever into the motherboard, because sometimes the BIOS is set from the factory in such a way that it always defaults to the motherboard output.


@BlueScope819 so I can see your post

#MuricaParrotGang

"My name is Legion 'Murica Parrot Gang, for we are many."

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, BlueScope819 said:

Perhaps try a different port from your graphics card? Try installing the graphics card but plugging the HDMI cable or whatever into the motherboard, because sometimes the BIOS is set from the factory in such a way that it always defaults to the motherboard output.

I already tried that it does the same thing

Link to post
Share on other sites
3 minutes ago, superspammer76 said:

Yes I did, all the bios settings should be right

So in your first post you said you bought this as a custom gaming PC? I would go ahead and return it because a. it's awful as a "new pc" and b, the graphics card clearly doesn't work.


@BlueScope819 so I can see your post

#MuricaParrotGang

"My name is Legion 'Murica Parrot Gang, for we are many."

Mentioned in 8/5/2020 TechLinked

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×