Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
kish

NZXT X73 coller for LGA 1200 socket

Recommended Posts

Posted · Original PosterOP

based on NZXT website the cooer X73 should be compatible with LGA 1200 intel socket.

 

But on the box and on the instruction it doesn't seem to indicate it is compatible.

 

Will I be able to fix them together ? Pls advise!

 

Link to post
Share on other sites

It will work. The mounting method and spacing is still the exact same as the 115X sockets. 


PSU Tier List Thread

 

"White Ice"

Ryzen 7 3700x | Asus Crosshair VIII Hero (Wi-Fi) | EVGA RTX 2080ti | Flare X 16-16-16-34 3600mhz 16gb | Full Custom Water Cooling Loop | 1tb Samsung 970 Evo

2tb Crucial MX500 SSD | 2x 3tb Seagate Drive | Fractal Design Meshify S2 |  EVGA G2 750w PSU | 3x Corsair LL140 | 3x Corsair LL120

 

Dedicated Streaming Rig

 Ryzen 7 1800x | Asus B450-F Strix | 16gb Vengeance LPX 3000mhz | Corsair RM550x (2018) | EVGA GTX 1060 3gb | 250gb 860 Evo m.2 | Phanteks Enthoo Evolv 

 Elgato HD60 Pro | Elgato 4k60 Pro mk.2 | Avermedia 4k GC573 Capture Card

 

Link to post
Share on other sites

I does work, the cooler came out before LGA 1200, LGA 115x coolers are fully compatible with LGA 1200


Main PC [The Rig of Theseus]:

CPU: i5-8600k@5.0GHz | GPU 1: GTX 1660@2070MHz | GPU 2: GT 710 | RAM: 16 GB DDR4 3000MHz | Case: Lian Li PC-O11 Dynamic | PSU: Corsair RM 650i | SSD: Corsair MP510 480GB & Kingston UV400 120GB |  HDD: 2x 2TB WD Black | Motherboard: Gigabyte Z390 Aorus Pro | OS: Windows 10 Pro & Linux Mint 

 

Secondary PC [Why did I bother]:

CPU: AMD Athlon 3000G | GPU: Vega 3 iGPU | RAM: 8 GB DDR4 3000MHz | Case: Corsair 88R | PSU: Corsair VS650 | SSD: WD Green M.2 SATA 120 GB | Motherboard: MSI A320M-A PRO MAX | OS: Windows 10 Pro

 

Server [Solution in search of a problem]:

Model: HP DL360e Gen8 | CPU: 1x Xeon E5-2430L v1 | RAM: 12 GB DDR3 1066MHz | SSD: Kingston A400 120GB | OS: Debian Buster

 

Laptop [A hunk of shit]:

Model: MacBook Air Late 2010 | CPU: Core 2 Duo L9600 | RAM: 4 GB DDR3 1066MHz | OS: MacOS Catalina 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×