Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
storm05

can any one help me?

Recommended Posts

Posted · Original PosterOP

i just got my new gpu it a gtx 1660 super, i got it all set upp up and when i strtet playing the game whud crash and somtimes restart the pc shuting it on and off.

i dont know why but it cud be the psu i am using a 350w psu i5 4466 and 8gb ram.

the game that i played was call of duty black ops 3

Link to post
Share on other sites

yes that could be the issue minimum needed for a 1660 super is a 450w psu. I suggest you get a better psu before bricking your whole pc. It also could also be that the drivers are not installed correctly. Use ddu and uninstall all the drivers and reinstall the new one from nividia geforce application. If the problem is still there then it is your psu which is most likely the issue. 

Link to post
Share on other sites

Which exact model of "350w" psu are we talking about? Most likely that's your issue.


CPU: AMD Ryzen 7 3700X - Motherboard: MSI B450 Tomahawk Max - GPU: Asus GTX 1080 Ti - RAM: 16 GB Crucial Ballistix 3600MHz cl16 - PSU: Corsair RMx 650W - Storage: 500 GB Samsung Evo 850 2,5" + 2 TB Samsung Evo 860 M.2 - Cooling: Noctua NH-D15 (CPU) + Raijintek Morpheus II (GPU) - Case: CoolerMaster Mastercase H500 - Fans: Noctua 2x NF-A20 (Front), 1x NF-A14 (Top back), 1x NF-F12 (Back), 2x NF-A12x15 (GPU) - Soundcard: Asus Xonar Essence STX II - Fan Controller: Corsair Commander Pro - OS: Windows 10 Pro - Monitor: AOC AG352UCG6 Secondary Monitor: AOC 24G2 HDR-Gaming-TV: LG C9 OLED 55" - Mouse: Corsair Dark Core RGB Pro SE Wireless - Keyboard: Corsair K63 Wireless + Lapboard - Headphones: Beyerdynamic DT990 Edition 600 Ohm - Microphone: Antlion ModMic

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Stahlmann98 said:

Which exact model of "350w" psu are we talking about? Most likely that's your issue.

i just re-instald my driver whit ddu and it was fixed the problem 

but i dont think that the psu is a huge problem i stres tested my gpu and cpu whit msi kumbostor, my cpu whas using 38w at max 

Link to post
Share on other sites
Posted · Original PosterOP

my old gpu was a gtx 760 2gb

but my system whas pre buldt msi nightblade

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×