Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Abhraneel Roy

Mobo showing Red Cpu Led

Recommended Posts

Posted · Original PosterOP

Before 1 hr i have been able to use this computer fine and have been able to use it for a year and never got any problems to play any games on it. 
Suddenly when i enabled fast boot from Windows , my pc restarted and now it wont boot...
Mobo showing red CPU light , would be on for 2s then turn off quickly then the DRAM led would flash on for a second and turn off and it would go back to the CPU led. It would cycle like this every 20 seconds
It used to work just an hour ago.
Dont know what to do right now.

Tried to reset Cmos using screwdriver but still not working.

Link to post
Share on other sites

remove coms battery, keep it out for 2-3 minutes(on the safer side). put it in and boot.
This will reset all bios settings to factory defaults


HI, if you liked what i said then please like

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, Srijan Verma said:

remove coms battery, keep it out for 2-3 minutes(on the safer side). put it in and boot.
This will reset all bios settings to factory defaults

Tried , still not working

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×