Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
kidjam86

Screen goes black suddenly

Recommended Posts

Posted · Original PosterOP

So I go to play Halo reach and stream it to twitch. About five minutes into an online match, my screen goes black. PC is still on but nothing is happening.. CPU fan set to turbo. GPU fans set to auto. So I am having to force shut off the PC and turn it back on. This does not happen when I go play rocket league and stream it.. Only with Halo Reach.. What in the world is going on with this thing?? 

 

B450-I gaming ROG strix

G. skill flare X 2 x 8GB 3200mhz

R5 2600 not OC'd

red dragon RX 580 8GB

600W Corsair PSU

Link to post
Share on other sites

Latest board bios?

Latest AMD chipset drivers (from AMD's website)?

Latest AMD GPU drivers (20.1.2 or 20.1.3. soon)?

RAM set to XMP?

 

I have such issues when running XMP. Once I turn XMP off everything runs perfectly stable (but RAM runs 2666).

Link to post
Share on other sites
Posted · Original PosterOP

Updated BIOS and GPU driver. All is well. Minus RAM not being able to run at 3200 now with new BIOS. Thanks for help. I should have known to check those. I just figured it would have been the game itself. 

Link to post
Share on other sites
12 hours ago, kidjam86 said:

Updated BIOS and GPU driver. All is well. Minus RAM not being able to run at 3200 now with new BIOS. Thanks for help. I should have known to check those. I just figured it would have been the game itself. 

Yeah, your RAM probably was not stable at your previous BIOS, so a more stable bios revealed the flaw. More stable bios's often reveal stability issues. You can either download MemTest64 or more preferably make a bootable USB and run MemTest86 (preferably) and find a more stable memory OC.


Specs

 

Ryzen 7 3700x | X570 Aorus Pro Wifi | 32GB (16x2) 16-16-16-36 G.Skill Trident Z RGB | MSI Gaming X Trio RTX 2080ti

Link to post
Share on other sites
Posted · Original PosterOP

Running memtest64 now. At the same time, my screen is flickering really badly now and my PC is freezing on me now... I just can't catch a break with this thing..

Link to post
Share on other sites

There is a known issue that I'm not sure if it's exclusive to the VII, or all AMD GPUs, where the driver stops responding for too long.  The monitor/s black out, and you have to restart your system.  I could never fix it, but it happened mainly in one game.   And, this only started happening recently.  I think AMD is working on fixing it.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in August for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 48 GB (2 x 16 GB + 2 x 8 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor (Replacing with an LG 4k IPS display for game art)+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP

Yeah it was the same this for me. I just had to update the bios and not the screens have yet to go black on me since then.. But no they flicker while streaming...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×