Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
reubixkube

RAM Compatibility Issues

Recommended Posts

Posted · Original PosterOP

I have a really weird issue, not sure if anyone on here might have a solution. I recently upgraded to 2x CMK16GX4M2A2400C16 and 2x CMK16GX4M2A2400C16R in my machine on a MSI Z270M Mortar  board with an Intel 7600K. 
The issue is it failed to post with the two red sticks, even after trying a single stick of each with just 1 stick of RAM in the machine, so I assumed they were DOA.

The weird part is they worked in my mates AsRock Z170 board running an 6600K without issues. Upon further inspection the set that works is Ver 3.31 while the not worked set is Ver 8.3 (I believe this is the specific DRAM chips based on what I can find online)

I have reset the BIOS after every failed boot/installing new RAM. Is it worth trying to update the BIOS or should I just get different RAM?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×