Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ty4755

internet connection times out randomly

Recommended Posts

Posted · Original PosterOP

My Wifi works fine but my Ethernet connected PC keeps dropping connection intermittently. I changed The Ethernet but same thing happens so it has to be my PC right? this just randomly started happening a week ago any help would be appreciated.

Link to post
Share on other sites

updated drivers? is this an old or new pc? is the router old or new? how many devices on the network?

Link to post
Share on other sites

Do you have another machine you can hook up via ethernet? If not, try updating your NIC's driver (should be found on your motherboard support page)


WHIPLASH

CPU: Intel Core i7 6700k @4.7GHz

RAM: Corsair Vengeance RGB DDR4 2x8GB @3000MHz

MOBO: Asus ROG Maximus VIII Ranger

GPU: EVGA GTX 1080 FTW2

PSU: EVGA Supernova 650GS

CASE: Fractal Design Define S

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, Saksham said:

updated drivers? is this an old or new pc? is the router old or new? how many devices on the network?

updated router and network adapters pc 4 years old AM3 motherboard  router fairly new  around 6 or 7 devices connected to network

Link to post
Share on other sites
Posted · Original PosterOP
19 minutes ago, toasty6776 said:

Do you have another machine you can hook up via ethernet? If not, try updating your NIC's driver (should be found on your motherboard support page)

NIC are network adapters right? I checked in device manager and says they are up to date and no I don't have another PC to test

Link to post
Share on other sites

Is it just your pc that gives you problems? Are you using Firefox? The most recent update to Firefox caused me similar issues. I have my DNS set to use NordVPN's DNS servers, and for some reason I needed to disable Firefox's DNS caching. I doubt this is your issue, but I figured I'd through this out there just in case.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, TempestCatto said:

Is it just your pc that gives you problems? Are you using Firefox? The most recent update to Firefox caused me similar issues. I have my DNS set to use NordVPN's DNS servers, and for some reason I needed to disable Firefox's DNS caching. I doubt this is your issue, but I figured I'd through this out there just in case.

ya just my pc other devices are connected wirelessly with no problems. I don't think its firefox cause i pinged google and it randomly drops out online games are unplayable  all I can do is browse the web wich drops connection every minute or so 

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, TempestCatto said:

Worth a shot then.

 

When I was having other issues, I had to flush my DNS cache in Windows. Have you tried that yet? https://www.noip.com/support/knowledgebase/how-do-i-flush-my-windows-dns-cache/

 

Also what do you mean when you say you "changed the Ethernet"?

1

ill try the DNS flush and I mean I changed the Ethernet cable to make sure it wasn't faulty 

Link to post
Share on other sites
8 hours ago, ty4755 said:

no change after DNS flush

I'm wondering if the Ethernet port on your motherboard is just going bad then. I had an older AM3+ 970 board that worked just fine, all except the Ethernet port which for some reason never really worked. If this is the case you could always buy a PCIe Ethernet card like this one https://www.amazon.com/Intel-Gigabit-Network-Adapter-EXPI9301CTBLK/dp/B001CY0P7G

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×