Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Ethernet Port Not Working

AxisHax
 Share

Two weeks ago my ISP came to upgrade the whole connection in my house after many complains about stability and service in general. I wasn't home when it happened, a relative of mine was, but when I arrived home I turned on my PC to check if everything was fine and there was no connection, the ethernet port had stopped working. I haven't had much time to work on it since.

Yesterday I tried uninstalling the drivers and rebooting the computer, but it didn't work.

One of the LEDs blinks orange when I plug the ethernet cable and then it turns off.

Link to comment
Share on other sites

Link to post
Share on other sites

Now I'm about to reinstall the LAN drivers through an USB drive.

Link to comment
Share on other sites

Link to post
Share on other sites

By the way the cable is not the problem, it works with other devices.

Link to comment
Share on other sites

Link to post
Share on other sites

Please, I need to fix this as soon as possible.

Does anyone know if there's a quick fix to this problem or I should just buy a PCIe network card?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×