Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Razer Synapse help!?

Hi!

I recently bought one of those razer keypads, and kinda happy with it. but there is a problem, i also have an old razer mice but it does not come up in the new razer synapse program. i can only edit it on the old one which does not want to for some reason to connect or talk to the new program. i dont know whats wrong, and ive done some googling but nothing that comes up helps. Any suggestions?

Thanks!

Link to comment
Share on other sites

Link to post
Share on other sites

Hi,

 

It happend to me something like that.

 

Razer Synapse 3 (most recent new version) does only support some devices (the most new) like for example, I have a razer kraken chroma 7.1 and there is a new version of that headset razer kraken chroma 7.1 V2, and razer synapse 3 works for the V2 version but does not support mine.

 

The razer synapse 2 does support that older devices, I do not know if the new devices are supported on this version synapse 2, but I would probably give it a try.

 

Is it stupid that new version the most recent synapse is only for new devices.

 

Hope it Helps.

 

Trokato Out

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, leander17king said:

Hi!

I recently bought one of those razer keypads, and kinda happy with it. but there is a problem, i also have an old razer mice but it does not come up in the new razer synapse program. i can only edit it on the old one which does not want to for some reason to connect or talk to the new program. i dont know whats wrong, and ive done some googling but nothing that comes up helps. Any suggestions?

Thanks!

What mouse and keypad do you have?

An older Razer mouse may incompatible with Synapse 3.

"Make sense? Oh, what fun is there in making sense?"
-Discord

Link to comment
Share on other sites

Link to post
Share on other sites

3 hours ago, Trokato said:

Hi,

 

It happend to me something like that.

 

Razer Synapse 3 (most recent new version) does only support some devices (the most new) like for example, I have a razer kraken chroma 7.1 and there is a new version of that headset razer kraken chroma 7.1 V2, and razer synapse 3 works for the V2 version but does not support mine.

 

The razer synapse 2 does support that older devices, I do not know if the new devices are supported on this version synapse 2, but I would probably give it a try.

 

Is it stupid that new version the most recent synapse is only for new devices.

 

Hope it Helps.

 

Trokato Out

It’s not necessarily that Synapse 3 won’t support these devices at all. Synapse 3 is in beta, with limited support for devices. They should be adding older ones soon.

import shittyTechAdvice as RollTime

 

Link to comment
Share on other sites

Link to post
Share on other sites

16 hours ago, RollTime said:

It’s not necessarily that Synapse 3 won’t support these devices at all. Synapse 3 is in beta, with limited support for devices. They should be adding older ones soon.

Yap, Probably when this version replace other versions will support all devices, but now is limited.

Check this link to see the supported devices for synapse 3:
https://www.razer.com/synapse-3

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×