Jump to content

New PC build won't POST/boot


I just upgraded my PC to a Ryzen CPU along with a new motherboard and memory. And now it won't POST; the computer turns on with the lights and fans working, but nothing comes on the screen or the RGB keyboard and mouse and no sound from the speaker (which came with my case). Also, I turn the power switch of the PSU on and the motherboard's RGB lights are turned on. Everything is connected properly, ATX power connector and all. I tried everything I could find on the Internet: I played around with the front panel plugs, switched the positions of the memory modules, replaced the CMOS battery, and even checked to see if my CPU is connected properly. What could be causing the PC not to boot?


Here is my build:

CPU: AMD Ryzen 2600


Motherboard: ASUS PRIME x470-PRO






5 Case Fans

PSU: Rosewill 600W 80 PLUS BRONZE-GOLD (don't recall)

UPS: CyberPower CP1500AVRLCD Intelligent LCD UPS System, 1500VA/900W, 12 Outlets, AVR, Mini-Tower


I've been using the same PSU since I bought my previous PC pre-built 3 years ago. The pre-built PC was an abs Stalker with an AMD FX-8350 and GTX 960. The website did not specify which specific PSU. I looked on the Power Supply Calculator and it recommended a PSU wattage of 409W and an 850W PSU. I'm pretty sure that my current PSU has enough power to support my PC build, and it was working with my previous hardware pretty well, even if I added more stuff to it...up to a point. Could the current PSU be the problem?


The monitor and the GTX 1060 work just fine. In fact, I used my GTX 1060 with my previous hardware and worked the last time I used it. Even without a GPU, the PC still won't boot.


I tried to reset the CMOS by following the documentation that came with my motherboard: by using a piece of metal such as a screwdriver to short the pins. I powered off and unplugged the PC, laid a screwdriver on top of the pins, plugged my PC back and turned on the power, and turned it on, but it didn't power on. I turned it back on without the screwdriver and it's still not booting up. I tried that with a USB cable; still nothing. I don't have any jumpers like we had in the old days.


I also tried to reset the CMOS by powering off and unplugging the PC, removed the battery, contacted my screwdriver with both pins for 5-10 seconds, then put everything back together, and it still won't POST.


UPDATE: I seem to have found the culprit. I turned the PC on one time and one of the RGB memory modules lit up. The other one did not. It has to do with me not installing the memory properly. :S I thought I was... In any case, I'm going to keep trying until both RGB memory modules light up.


UPDATE 2: My PC is up and running! Finally! Thank goodness I chose to have RGB DDR4 modules. Not only do they make my PC look nicer, but they were also a guideline to tell me if I've installed them properly or not. No light, no boot. I'll remember that the next time I buy RGB memory.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now