Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Help

Darkdestroyer445
 Share

So I'm not home to try anything at the moment BUT I got a Asus Socket FM2+ A88XX and I have 12gb of ddr3 ram installed, a GTX 1050 ti and a x4 860k in it but Everytime I press the power button, it comes on but never displays anything. Please help.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Darkdestroyer445 said:

So I'm not home to try anything at the moment BUT I got a Asus Socket FM2+ A88XX and I have 12gb of ddr3 ram installed, a GTX 1050 ti and a x4 860k in it but Everytime I press the power button, it comes on but never displays anything. Please help.

Confirm no power or data connections have been jarred loose and clear the CMOS. Make sure your cards and RAM are seated correctly. 

AMD FX™ 6300 @ 4.51 GHz | ASUS M5A97 R2.0 | Sapphire Radeon HD 7850 2GB OC | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | ASUS Xonar DG | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5  | ASUS ProArt PA238QR

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 15.4.1) | iPhone XR (iOS 15.4.1) |  iPad Mini (iOS 9.3.5) | KZ AZ09 Pro x KZ ZSN Pro X

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, BlueChinchillaEatingDorito said:

Confirm no power or data connections have been jarred loose and clear the CMOS. Make sure your cards and RAM are seated correctly. 

This,

Also make sure the PSU is turned on

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Crunchy Dragon said:

This,

Also make sure the PSU is turned on

Ah yes, can't forget the typical IT desk response. xD Though he says it does light up so I guess it's safe to assume it is turned on. 

AMD FX™ 6300 @ 4.51 GHz | ASUS M5A97 R2.0 | Sapphire Radeon HD 7850 2GB OC | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | ASUS Xonar DG | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5  | ASUS ProArt PA238QR

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 15.4.1) | iPhone XR (iOS 15.4.1) |  iPad Mini (iOS 9.3.5) | KZ AZ09 Pro x KZ ZSN Pro X

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, BlueChinchillaEatingDorito said:

Ah yes, can't forget the typical IT desk response. xD Though he says it does light up so I guess it's safe to assume it is turned on. 

Oh true lol. I'm looking at going into IT so I'm working on the responses(jk)

 

That was the first mistake I made in my build though so I tend to recommend it where I can

Quote or tag me( @Crunchy Dragon) if you want me to see your reply

If my post solved your problem/answered your question, please consider marking it as "solved"

Community Standards // PSU Tier List // Bugs and Issues // Join Floatplane! // Join the LTT Official Discord //

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, Crunchy Dragon said:

Oh true lol. I'm looking at going into IT so I'm working on the responses(jk)

 

That was the first mistake I made in my build though so I tend to recommend it where I can

Same. My first response here used to always be ...

AAEAAQAAAAAAAAdbAAAAJDNlZWVmOWY4LTY2MmUt

AMD FX™ 6300 @ 4.51 GHz | ASUS M5A97 R2.0 | Sapphire Radeon HD 7850 2GB OC | 24GB Kingston DDR3 | Samsung 850 EVO 250GB WD Green 1.5TB | ASUS Xonar DG | Windows 10 Pro

Sony MDR-V250 | GNT-500 | Logitech G610 Orion Brown | Logitech G402 | Samsung C27JG5  | ASUS ProArt PA238QR

Intel Core™ i7-7600U | Seagate 500GB HDD | 16GB DDR4 | Windows 10 Enterprise | HP EliteBook 850 G4

Intel Core™ i5-8520U | WD Blue M.2 250GB | 1TB Seagate FireCuda | 8GB DDR4 | Windows 11 Home | ASUS Vivobook 15 

Intel Core™ i7-3520M | GT 630M | 16 GB Corsair Vengeance DDR3 | Samsung 850 EVO 250GB | macOS Catalina  Lenovo IdeaPad P580

iPhone 12 Mini (iOS 15.4.1) | iPhone XR (iOS 15.4.1) |  iPad Mini (iOS 9.3.5) | KZ AZ09 Pro x KZ ZSN Pro X

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, BlueChinchillaEatingDorito said:

Same. My first response here used to always be ...

AAEAAQAAAAAAAAdbAAAAJDNlZWVmOWY4LTY2MmUt

Can confirm. I don't say it in Roy's voice, but I do have to ask that on occasion.

CPU: Core i7 4970K | MOBO: Asus Z87 Pro | RAM: 32GBs of G.Skill Ares 1866 | GPU: MSI GAMING X GTX 1070 | STOR: 2 X Crucial BX100 250GB, 2 x WD Blk 1TB (mirror),WD Blk 500GB | CASE: Cooler Master HAF 932 Advanced | PSU: EVGA SUPERNOVA G2 750W | COOL: Cooler Master Hyper T4 | DISP: 21" 1080P POS | KB: MS Keyboard | MAU5: Redragon NEMEANLION | MIC: Snowball Blue | OS: Win 8.1 Pro x64, (Working on Arch for dual boot) |

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Gikero said:

Can confirm. I don't say it in Roy's voice, but I do have to ask that on occasion.

Would it be that I have to update BIOS for some reason?

 

Link to comment
Share on other sites

Link to post
Share on other sites

16 hours ago, Darkdestroyer445 said:

Would it be that I have to update BIOS for some reason?

 

Did you follow the previously mentioned suggestions already? Do you have a PC speaker connected to the speaker motherboard header?  Is it a new build or did it work and suddenly stop working?

CPU: Core i7 4970K | MOBO: Asus Z87 Pro | RAM: 32GBs of G.Skill Ares 1866 | GPU: MSI GAMING X GTX 1070 | STOR: 2 X Crucial BX100 250GB, 2 x WD Blk 1TB (mirror),WD Blk 500GB | CASE: Cooler Master HAF 932 Advanced | PSU: EVGA SUPERNOVA G2 750W | COOL: Cooler Master Hyper T4 | DISP: 21" 1080P POS | KB: MS Keyboard | MAU5: Redragon NEMEANLION | MIC: Snowball Blue | OS: Win 8.1 Pro x64, (Working on Arch for dual boot) |

Link to comment
Share on other sites

Link to post
Share on other sites

21 hours ago, Gikero said:

Did you follow the previously mentioned suggestions already? Do you have a PC speaker connected to the speaker motherboard header?  Is it a new build or did it work and suddenly stop working?

No I do not. And it's a new build.

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Darkdestroyer445 said:

No I do not. And it's a new build.

 

I would get a PC speaker that connects to the header on your motherboard. They're usually $5 or so. It can produce beep error codes on bootup, which will help you narrow down what your issue is more effectively. Most motherboard manuals have a section for beep codes and what they relate to.

CPU: Core i7 4970K | MOBO: Asus Z87 Pro | RAM: 32GBs of G.Skill Ares 1866 | GPU: MSI GAMING X GTX 1070 | STOR: 2 X Crucial BX100 250GB, 2 x WD Blk 1TB (mirror),WD Blk 500GB | CASE: Cooler Master HAF 932 Advanced | PSU: EVGA SUPERNOVA G2 750W | COOL: Cooler Master Hyper T4 | DISP: 21" 1080P POS | KB: MS Keyboard | MAU5: Redragon NEMEANLION | MIC: Snowball Blue | OS: Win 8.1 Pro x64, (Working on Arch for dual boot) |

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×