Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SSD problem

Hey, so a friend of mine recently told me his SSD failed, and is only shown as  2MB (yes 2mb) unit, ive tried anything but i cant the drive get recognized for anything else, and it literally crashes crystal disk info
The disk is a Silicon Power Velox  V55, i cant find any info on the controller it uses, but ive heard Sandforce ones tend to fail this way, i the firmware utility provided by the page doesnt recognize the disk either, so im at a loss here

Main PC:| CPU: Ryzen 5 2600 @ 4.1, MOBO: Asus B350 PRIME , RAM: LPX Vengance 2400 16gb kit, GPU: 980Ti Poseidon Platinum 6gb
                PSU: SilverStone Strider Gold Evolution 1200w , CASE: HAF 932  HDDs:240gb EX900 HP NVME 6TB (2x3 Seagate Barracuda)
                COOLING: ThermalTake Contac Silent 12
Laptop:MSI GL62 7RD  CPU: Core i5 7300HQ, RAM: 16GB 2400mhz, :GPU GTX 1050 2GB: HDDs: 256gb adata NVME + 1TB HDD
 

love all brands, will go for whats cheaper for my needs

Link to comment
Share on other sites

Link to post
Share on other sites

If you have warranty use it.

Link to comment
Share on other sites

Link to post
Share on other sites

42 minutes ago, Almostbauws said:

If you have warranty use it.

the warranty is as dead as the SSD, its been 3 years since purchase,

Main PC:| CPU: Ryzen 5 2600 @ 4.1, MOBO: Asus B350 PRIME , RAM: LPX Vengance 2400 16gb kit, GPU: 980Ti Poseidon Platinum 6gb
                PSU: SilverStone Strider Gold Evolution 1200w , CASE: HAF 932  HDDs:240gb EX900 HP NVME 6TB (2x3 Seagate Barracuda)
                COOLING: ThermalTake Contac Silent 12
Laptop:MSI GL62 7RD  CPU: Core i5 7300HQ, RAM: 16GB 2400mhz, :GPU GTX 1050 2GB: HDDs: 256gb adata NVME + 1TB HDD
 

love all brands, will go for whats cheaper for my needs

Link to comment
Share on other sites

Link to post
Share on other sites

On 17/10/2017 at 11:41 AM, Biggerboot said:

Is the SSD recognized in Diskpart or GParted?

only as a 2mb unit

Main PC:| CPU: Ryzen 5 2600 @ 4.1, MOBO: Asus B350 PRIME , RAM: LPX Vengance 2400 16gb kit, GPU: 980Ti Poseidon Platinum 6gb
                PSU: SilverStone Strider Gold Evolution 1200w , CASE: HAF 932  HDDs:240gb EX900 HP NVME 6TB (2x3 Seagate Barracuda)
                COOLING: ThermalTake Contac Silent 12
Laptop:MSI GL62 7RD  CPU: Core i5 7300HQ, RAM: 16GB 2400mhz, :GPU GTX 1050 2GB: HDDs: 256gb adata NVME + 1TB HDD
 

love all brands, will go for whats cheaper for my needs

Link to comment
Share on other sites

Link to post
Share on other sites

Well, it’s probably dead. Just replace it. 

Main System: Phobos

AMD Ryzen 7 2700 (8C/16T), ASRock B450 Steel Legend, 16GB G.SKILL Aegis DDR4 3000MHz, AMD Radeon RX 570 4GB (XFX), 960GB Crucial M500, 2TB Seagate BarraCuda, Windows 10 Pro for Workstations/macOS Catalina

 

Secondary System: York

Intel Core i7-2600 (4C/8T), ASUS P8Z68-V/GEN3, 16GB GEIL Enhance Corsa DDR3 1600MHz, Zotac GeForce GTX 550 Ti 1GB, 240GB ADATA Ultimate SU650, Windows 10 Pro for Workstations

 

Older File Server: Yet to be named

Intel Pentium 4 HT (1C/2T), Intel D865GBF, 3GB DDR 400MHz, ATI Radeon HD 4650 1GB (HIS), 80GB WD Caviar, 320GB Hitachi Deskstar, Windows XP Pro SP3, Windows Server 2003 R2

Link to comment
Share on other sites

Link to post
Share on other sites

12 hours ago, Mauricio G. B. said:

only as a 2mb unit

No unallocated space on the drive?  Just the 2mb unit?

As a last ditch effort I would try different sata power and data cables (and a different port).

Sounds likely to be dead though.

Link to comment
Share on other sites

Link to post
Share on other sites

On 19/10/2017 at 1:54 PM, Biggerboot said:

No unallocated space on the drive?  Just the 2mb unit?

As a last ditch effort I would try different sata power and data cables (and a different port).

Sounds likely to be dead though.

tried on 5 diferent pcs, only shows as a 2mb unit, ive heard it has something to do with the sandforce controller

Main PC:| CPU: Ryzen 5 2600 @ 4.1, MOBO: Asus B350 PRIME , RAM: LPX Vengance 2400 16gb kit, GPU: 980Ti Poseidon Platinum 6gb
                PSU: SilverStone Strider Gold Evolution 1200w , CASE: HAF 932  HDDs:240gb EX900 HP NVME 6TB (2x3 Seagate Barracuda)
                COOLING: ThermalTake Contac Silent 12
Laptop:MSI GL62 7RD  CPU: Core i5 7300HQ, RAM: 16GB 2400mhz, :GPU GTX 1050 2GB: HDDs: 256gb adata NVME + 1TB HDD
 

love all brands, will go for whats cheaper for my needs

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×