Jump to content

GPU still struggling

trillin
 Share

Go to solution Solved by BetteBalterZen,
3 minutes ago, trillin said:

ok I think this should be it

cpu temps.png

Oh crap, that is not good. Your CPU is probably thermal throttling a lot, which is harming the performance. 

 

Make sure the CPU cooler is mounted properly and maybe also apply some new thermal paste while you're at it 🙂

Since the Most Recent update to Nvidia drivers My PC is struggling to play simple games like minecraft, I have a 1660 Super and have tried uninstalling and reinstalling drivers, as well as doing a clean boot, nothing is running hot (from what I can tell). My hardware is a few years older but it was working fine last week. the GPU is fairly new so it shouldn't have any issues. any insight would be greatly appreciated. My next step is just doing a fresh install on Windows and seeing if that fixes the issue

Link to comment
Share on other sites

Link to post
Share on other sites

Can you share some numbers? 

FPS
Clockspeeds
Temperatures 

etc... 

:) 

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, BetteBalterZen said:

Can you share some numbers? 

FPS
Clockspeeds
Temperatures 

etc... 

🙂

sorry still new to the world of PC gaming, any recommendations for programs to view all that?

Link to comment
Share on other sites

Link to post
Share on other sites

not sure if this is any help but it looks like my CPU usage is hitting high 90's up to 100% and my GPU is barely breaking 30% usage, could that be doing something to affect gameplay?

stats.png

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, trillin said:

not sure if this is any help but it looks like my CPU usage is hitting high 90's up to 100% and my GPU is barely breaking 30% usage, could that be doing something to affect gameplay?

stats.png

Looks like a big bottleneck yes. What CPU do you have? What resolution do you play in? 

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, BetteBalterZen said:

Looks like a big bottleneck yes. What CPU do you have? What resolution do you play in? 

Running an intel i7-4790 @ 3.60 GHz,  monitors are 16:10 1680x1050 each

Link to comment
Share on other sites

Link to post
Share on other sites

19 hours ago, trillin said:

Running an intel i7-4790 @ 3.60 GHz,  monitors are 16:10 1680x1050 each

Yeah such a low resolution with a very old CPU. Pretty sure it's simply a bottleneck issue. I know you said this began happening after the latest Nvidia driver but are you certain of that? 

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

43 minutes ago, BetteBalterZen said:

Yeah such a low resolution but a very old CPU. Pretty sure it's simply a bottleneck issue. I know you said this began happening after the latest Nvidia driver but are you certain of that? 

nothing is ever certain, my friend I have also chatted with Nvidia support and changed a bunch of settings as well as performed multiple clean tools and clean boots, my next step is a fresh windows install but I am hesitant to do it if it will not fix the problem. Not that I have much on here other than gaming I only use it for work which I do thorough a Virtual PC. I did notice that some of the clips on my cooler fan looked like maybe they were a little loose so I had tried to tighten them a bit one day but they didn't move and I didn't use much force as it was mounted when I received the PC 

Link to comment
Share on other sites

Link to post
Share on other sites

17 hours ago, BetteBalterZen said:

Yeah such a low resolution but a very old CPU. Pretty sure it's simply a bottleneck issue. I know you said this began happening after the latest Nvidia driver but are you certain of that? 

Just finished doing a factory reset on windows and the problem seems to be on going, really hope there is a way I can fix this without getting a new CPU

Link to comment
Share on other sites

Link to post
Share on other sites

11 minutes ago, trillin said:

Just finished doing a factory reset on windows and the problem seems to be on going, really hope there is a way I can fix this without getting a new CPU

You mentioned the CPU cooler might be loose. What temps are you seeing? Use fx HWiNFO to monitor temps

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, BetteBalterZen said:

You mentioned the CPU cooler might be loose. What temps are you seeing? Use fx HWiNFO to monitor temps

ok I think this should be it

cpu temps.png

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, trillin said:

ok I think this should be it

cpu temps.png

Oh crap, that is not good. Your CPU is probably thermal throttling a lot, which is harming the performance. 

 

Make sure the CPU cooler is mounted properly and maybe also apply some new thermal paste while you're at it 🙂

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, BetteBalterZen said:

Oh crap, that is not good. Your CPU is probably thermal throttling a lot, which is harming the performance. 

 

Make sure the CPU cooler is mounted properly and maybe also apply some new thermal paste while you're at it 🙂

Thanks, I will give it a shot and let you know

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, BetteBalterZen said:

Oh crap, that is not good. Your CPU is probably thermal throttling a lot, which is harming the performance. 

 

Make sure the CPU cooler is mounted properly and maybe also apply some new thermal paste while you're at it 🙂

Going to pick up thermal paste in a bit, also thinking about maybe picking up a small AIO, curious as to what you think of this?  https://www.bestbuy.ca/en-ca/product/corsair-hydro-h60-120mm-all-in-one-liquid-cpu-cooling-system/14194610

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, trillin said:

Going to pick up thermal paste in a bit, also thinking about maybe picking up a small AIO, curious as to what you think of this?  https://www.bestbuy.ca/en-ca/product/corsair-hydro-h60-120mm-all-in-one-liquid-cpu-cooling-system/14194610

Not really a good AIO, I would go with a good air cooler like the Scythe Fuma II Rev B or if you are on a budget the Vetroo V5

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, NF-A12x25 said:

Not really a good AIO, I would go with a good air cooler like the Scythe Fuma II Rev B or if you are on a budget the Vetroo V5

Thanks, I am hoping i can continue using my stock cooler but I am just thinking worst case 

Link to comment
Share on other sites

Link to post
Share on other sites

26 minutes ago, trillin said:

Going to pick up thermal paste in a bit, also thinking about maybe picking up a small AIO, curious as to what you think of this?  https://www.bestbuy.ca/en-ca/product/corsair-hydro-h60-120mm-all-in-one-liquid-cpu-cooling-system/14194610

95 cad for a 120 aio is a ripoff. For that price for You can get a scythe fuma rev b for 90 cad which is an objectively better cooler.

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, trillin said:

Thanks, I am hoping i can continue using my stock cooler but I am just thinking worst case 

Just buy a decent air cooler, it pretty much lasts forever. Unless you physically abuse it.
The fan will break at one point, but as long the air cooler is using standard shape 120mm or 140mm fan & fan mounting system, you can easily replace it with any brand.

Your CPU will thank you, future you will thank you.

There is approximately 99% chance I edited my post

Refresh before you reply

__________________________________________

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, Ryuikko said:

95 cad for a 120 aio is a ripoff. For that price for You can get a scythe fuma rev b for 90 cad which is an objectively better cooler.

Thanks for the input, fingers crossed 

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Poinkachu said:

Just buy a decent air cooler, it pretty much lasts forever. Unless you physically abuse it.
The fan will break at one point, but as long the air cooler is using standard shape 120mm or 140mm fan & fan mounting system, you can easily replace it with any brand.

Your CPU will thank you, future you will thank you.

I am going to try the stock again after cleaning first but thanks for the advice I will be keeping an eye on things

Link to comment
Share on other sites

Link to post
Share on other sites

58 minutes ago, trillin said:

I am going to try the stock again after cleaning first but thanks for the advice I will be keeping an eye on things

The price for the H60 might be a bad deal but I can say that I used the first ever version of the H60 with the i7-3770K I had back in the day, and it worked just fine at stock. But after I started overclocking, I did upgrade to a 240 AIO. 

Was the old thermal paste dried out? Was the spread even? 🙂

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, BetteBalterZen said:

The price for the H60 might be a bad deal but I can say that I used the first ever version of the H60 with the i7-3770K I had back in the day, and it worked just fine at stock. But after I started overclocking, I did upgrade to a 240 AIO. 

Was the old thermal paste dried out? Was the spread even? 🙂

I haven't taken it off yet i was nervous to do it without any new paste, heading over to pick it up now, nearest place is 30 min drive

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, trillin said:

I haven't taken it off yet i was nervous to do it without any new paste, heading over to pick it up now, nearest place is 30 min drive

Roger that 🙂

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, BetteBalterZen said:

Roger that 🙂

Just removed the cooler not sure if this looks good or bad but cleaning it up now

20220820_165309_HDR.jpg

20220820_165231.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, trillin said:

Just removed the cooler not sure if this looks good or bad but cleaning it up now

20220820_165309_HDR.jpg

20220820_165231.jpg

That spread looks really bad man... Really bad. No wonder the temps were high. Some new thermal paste and a proper even mount will without doubt help on temps, I really believe that. 

There's no place like 127.0.0.1 💙

 

Expand for setup details:

 

MOBO: ASUS ROG STRIX Z370-F Gaming  

CPU: Intel Core i7-8700K@4.7GHz, -0.095mV (Custom CNP-IHS + LM) 

CPU COOLER: CORSAIR Hydro Series H100x + 2x CORSAIR 120LL RGB

GPU: ASUS ROG STRIX RTX 3080 Ti OC LC@1950MHz (300W optimized undervolt profile)

RAM: G.SKILL TridentZ RGB 4x8GB@3700MT/s, 16-16-16-36, 1.35V (XMP Profile + 100MHz)

PCIe USB-A BOARD: ST Lab PCI-e 3.0 USB 3.1 (4x USB-A ports)

NVMe SSD: Samsung 970 EVO Plus 1TB 

#1 SATA SSD: Crucial MX500 2TB (1.05TB Partition RAID 0 striped with #2 SATA SSD: MX300)

#2 SATA SSD: Crucial MX300 1.05TB (RAID 0 striped with 1.05TB Partition on #1 SATA SSD: MX500)

PSU: CORSAIR HXi Series HX1200i (1200 Watt 80-PLUS Platinum)

CASE: CORSAIR iCUE 7000X RGB TG

CASE FANS: 4x CORSAIR SP140 RGElite, 2x CORSAIR 120LL RGB

#1 MONITOR: Samsung 49" Odyssey CRG9 QLED (32:9, 5120x1440p@120Hz, 8bit RGB, HDR1000)

#2 MONITOR: Samsung 49" Odyssey G9 QLED (32:9, 5120x1440p@240Hz, 10bit RGB, HDR1000) [used on Svive Racing D1 SIM Cockpit]

#3 MONITOR: Philips 34" 346B1C (21:9, 3440x1440p@100Hz, 8bit RGB[used with Lenovo ThinkCentre Tiny]

SPEAKERS: CORSAIR SP2500 + FX Audio DAC-X6

 

Full specs and setup details on my profile-page

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×