Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

my pc turns on but nothing happens on the monitor and when i try to turn it off with the case power button it just flashes on and off until i let go

arya.tikku
 Share

 my pc turns on but nothing happens on the monitor and when i try to turn it off with the case power button it just flashes on and off until i let go

Link to comment
Share on other sites

Link to post
Share on other sites

Can you start by listing your full system specs?

PSU Tier List Thread | Community Standards | Fan Control Software

Please make sure to Quote me or @ me to see your reply!

Just because I am a Moderator does not mean I am always right. Please fact check me and verify my answer. 

 

"White Ice"

Ryzen 9 5900x | Asus Crosshair VIII Hero (Wi-Fi) | EVGA RTX 2080ti | Ballistix 32gb 16-18-18-36 3600mhz | Custom Water Loop | 1tb Samsung 970 Evo

2x 2tb Crucial MX500 SSD | Fractal Design Meshify S2 | Corsair HX850 PSU | 3x Corsair LL140 | 3x Corsair LL120

 

Dedicated Streaming Rig

 Ryzen 7 3700x | Asus B450-F Strix | 32gb Gskill Flare X 3200mhz | Corsair RM550x PSU | Asus Strix GTX1070 | 250gb 860 Evo m.2

Phanteks Enthoo Evolv |  Elgato HD60 Pro | Avermedia Live Gamer Duo | Avermedia 4k GC573 Capture Card

 

Link to comment
Share on other sites

Link to post
Share on other sites

5 minutes ago, Skiiwee29 said:

Can you start by listing your full system specs?

ryzen 5 2600

rtx 3060

gigabyte b450m ds3h

evga psu 650 w

 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, arya.tikku said:

ryzen 5 2600

rtx 3060

gigabyte b450m ds3h

evga psu 650 w

 

You have your video cable plugged into the GPU and not the Motherboard correct?

PSU Tier List Thread | Community Standards | Fan Control Software

Please make sure to Quote me or @ me to see your reply!

Just because I am a Moderator does not mean I am always right. Please fact check me and verify my answer. 

 

"White Ice"

Ryzen 9 5900x | Asus Crosshair VIII Hero (Wi-Fi) | EVGA RTX 2080ti | Ballistix 32gb 16-18-18-36 3600mhz | Custom Water Loop | 1tb Samsung 970 Evo

2x 2tb Crucial MX500 SSD | Fractal Design Meshify S2 | Corsair HX850 PSU | 3x Corsair LL140 | 3x Corsair LL120

 

Dedicated Streaming Rig

 Ryzen 7 3700x | Asus B450-F Strix | 32gb Gskill Flare X 3200mhz | Corsair RM550x PSU | Asus Strix GTX1070 | 250gb 860 Evo m.2

Phanteks Enthoo Evolv |  Elgato HD60 Pro | Avermedia Live Gamer Duo | Avermedia 4k GC573 Capture Card

 

Link to comment
Share on other sites

Link to post
Share on other sites

41 minutes ago, Skiiwee29 said:

You have your video cable plugged into the GPU and not the Motherboard correct?

ya 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

Newegg

×