Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hardware or Software USB Problem

Last night for some reason my mouse stopped working. I figured I'd check it out this morning.


As far as I can determine the USB port is both alive and dead.

Hear me out.

I plug something simple into it, say to charge a device the port works fine.

If I need two way communication (keyboard, mouse, phone for moving info) it doesn't pick it up.

As this happened my 5.0 GPS network port stopped working, 2.5 still works.

This is on an ASUS ROG X570 Crosshair VIII Hero motherboard.

Any ideas or time to call ASUS and say hello warranty!

 

Link to comment
Share on other sites

Link to post
Share on other sites

Call ASUS and start an RMA, I highly doubt it's something you did or changed somewhere that you could revert back, it sounds more like a hardware failure to me.

System Specs:

          "Beatrix"

  • CPU AMD Ryzen 7 3700X
  • Motherboard GIGABYTE X570 I AORUS Pro Wi-Fi
  • RAM 2 x 16GB Corsair Vengeance RGB Pro @ 3200mhz CL16
  • GPU EVGA Geforce GTX 1080 SC
  • Case Corsair Crystal 280x
  • Storage 1x Samsung 980 Pro (1TB) 1x Samsung Evo Plus (500GB) 1x Samsung 860 Evo (1TB)
  • PSU EVGA 850 GQ
  • Display(s) 27" Viewsonic XG2705
  • Cooling Corsair H100i Elite Capellix AIO | 4x QL120 RGB fans | 2x QL140 RGB fans
  • Keyboard Logitech G213
  • Mouse Logitech G502 Lightspeed /w Powerplay
  • Sound Corsair HS60 Pro
  • Operating System Windows 10 Professional 21H1
Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×