Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Dram Problem after 2 Years

First of all my Build information:

Ryzen 9 3900x with stock cooler (Wraith Prism)

MSI b450 Pro Carbon AC / ASUS ROG B550F Gaming WIFI

32gb Corsair Vengeance 3000mhz (4 x 8GB)

MSI RTX 2080 Super Gaming X Trio

500 GB m.2 samsung evo 970

1TB patriot burst SSD

Bequiet Pure Power 11 600W (modular)

 

Hi, my build has been running for 2 Years without any hickups whatsoever. A couple of Days ago it randomly shut down without any warning while watching a video (I was not stressing the system whatsoever as you could imagine from the specs above). I tried to restart the PC but it would not boot. All the fans would spin really fast and the DRAM LED would be glowing (not flashing, if it can even do that) constantly until i shut down my computer again byy holding down the power button. I tried starting it with one stick of ram in slot 1 (the one nearest to the CPU) and it bootet just fine. So I tested all the Ram sticks individually in Slot 1. Every Ram stick was working fine. I then proceeded to test the other slots. Turns out with a single Ram stick in slot 3 or 4 the system would again show the DRAM error. 1 and 2 were working just fine (not with both sticks in them tho. Either one stick in 1 or one stick in 2). I flashed CMOS and updated the bios still nothing. I baught a new Mobo (the second one mentioned in the specs) and swapped it with the old one thinking that would be the end of my problems. The Problem persists. But now every channel works and i can get the PC working with 2 sticks of Ram in slot 3 and 4 (those were dead on the other mobo). So now i can use 2 sticks of Ram but still not 4. whenever I try to install a third or even fourth Ram stick in slot 1 or 2 i get the DRAM error. If I install only one stick of Ram in either of those slots, the PC is booting just fine. I found some Forum posts narrowing this issue down to 2 components the PSU that is somehow acting up when trying to use dual channel memory or the CPU. The thing is: every one with the CPU problem had bent pins from installing the CPU. Their errors occured right after build and NOT years later. How can I bent a pin while the CPU is sitting in its slot? That seems impossible. Also, while swapping the CPU to the other mobo I did not see any bent pins. It went in the other mobo like butter and everything is working (e.g. stress testing with high temperatures or long use for several hours). I ordered the exact same Power supply from Amazon hoping this will fix things. If that is not it, I will have to sent the CPU to AMD hoping they find something.

 

My question now is: is there another solution I did not think of/find? My CPU cooler is not overtightened (it has this weird clamp system that comes witrh the stock cooler, no screws involved)

Link to post
Share on other sites

The single stick thing is a useful and interesting but time consuming task that can have holes in it.  I might want to run memtest86 if possible.  It’s old too but not as old.  It’s faster though and tests ram in a different way.  Might show something. It’s at least cheap.

Life is like a bowl of chocolates: there are all these little crinkly paper cups everywhere.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×