Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Why not more FPS?

Hello guys, just installed msi afterburner to have a look a the numbers. 

 

I did a check while playing KSP, and I got what i have on the image:

 

GPU: 47°C, 35% Usage

CPU: 74°C, 39% Usage

D3D11 (FPS): 46FPS

 

Why don't i get more FPS?

 

Rig:

MB ASUS P8H67 rev 3.00
MEMORY 2x KVR1333D3N9/4G
  2x KVR1333D3S8N9/2G
CPU INTEL CORE i7 2600
GC GIGABYTE Geforce GTX 1060 WINDFORCE OC 6gb
DRIVE SAMSUNG SSD PRO 256GB
NETWORK TP-LINK 300Mbps Wireless N Adapter
PSU XILENCE XP600.(135)R3

uages_ksp.png

Link to post
Share on other sites

You could be limitied because it uses only one core, to low of a resolution for the gpu to really have to do anything, bad optimization, game engine limitations,....

GUITAR BUILD LOG FROM SCRATCH OUT OF APPLEWOOD

 

- Ryzen Build -

R5 3600 | MSI X470 Gaming Plus MAX | 16GB CL16 3200MHz Corsair LPX | Dark Rock 4

MSI 2060 Super Gaming X

1TB Intel 660p | 250GB Kingston A2000 | 1TB Seagate Barracuda | 2TB WD Blue

be quiet! Silent Base 601 | be quiet! Straight Power 550W CM

2x Dell UP2516D

 

- First System (Retired) -

Intel Xeon 1231v3 | 16GB Crucial Ballistix Sport Dual Channel | Gigabyte H97 D3H | Gigabyte GTX 970 Gaming G1 | 525 GB Crucial MX 300 | 1 TB + 2 TB Seagate HDD
be quiet! 500W Straight Power E10 CM | be quiet! Silent Base 800 with stock fans | be quiet! Dark Rock Advanced C1 | 2x Dell UP2516D

Reviews: be quiet! Silent Base 800 | MSI GTX 950 OC

 

Link to post
Share on other sites

KSP isn't the best benchmark for any kind of gaming. The engine is a mess, it's really not optimized for... Anything. And without knowing what settings you're using, it's... Pointless? I mean, if you're running an 8k monitor, and running the game at 8k, I would seriously tell you 'that's amazing!', or you could be running at 720p, with all of your settings turned all the way down, and I would tell you 'something is horribly wrong with that'.

 

Bah. You're going to make me install KSP on my new machine to see what it can do.

 

Also for a point of reference, my Haswell Xeon, 980, and 32GB of RAM system was getting around the same FPS when running it on my 1080p monitor, but my temps were waaaay lower than yours, but that would more likely be due to case design and airflow than anything else.

Have you tried unplugging it and plugging it back in? Yes? Then have you tried downloading more RAM?

Link to post
Share on other sites

I ran KSP on my Ryzen 9 3900x with the placeholder 980 in it, and with everything turned up, at 1080p, I was getting 45-50 FPS on ascent, and 80+ in orbit. I was seeing one core at about 80% utilization, two cores at 50%, and the rest sat at pretty much idle.

 

There seems to be some issues with the game, since it wasn't pegging a single core, and the GPU sat at 30-40% utilization.

Have you tried unplugging it and plugging it back in? Yes? Then have you tried downloading more RAM?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×