Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Alien Isolation: Error Save

So lately I have been playing alien isolation, all of my saves were fine and all until I reached chapter 5 and I started getting these errors, I have tried everything from deleting, cleaning out my hard drive of any junk, uninstalling and installing again to no avail. I decided to start a new game since I thought my game save might have corrupted, so I went on and did it but not even loading into the intro scene, the game gave me the same error??? How can I fix this? I can't seem to find anything relevant on this error. (FYI: I downloaded the game through the Xbox Beta app since the game came free with the Xbox Game Pass)

61211413974--F459A367-519A-49D6-AA5E-4F60F9FC9154.JPG

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×