Jump to content

PC stutter/hitching during gameplay and webbrowsing

Mikool

Hello. For some time now I have had occasional stutters/hitching/fps drops while playing games, however it was never bad enough to make me look into it. Then a few days ago I got myself a new 1440p 144hz monitor and suddenly my PC stutters way more than normal when set to 1440p, both during gameplay and when I just surf the web. The audio starts crackling too. I have tested on a few different monitors now, so the monitor is not at fault. This is getting very tiresome as I don't believe my system should be during this. I hope someone will be able to help! Thank you in advance

 

Specs are:
Mobo: Asus STRIX Z270F GAMING, latest bios

CPU: i7-7700k running at 4.5ghz turbo
GPU: Asus GTX 1080 Ti 11GB ROG Strix
SSD, Bootdrive: Samsung 860 evo 500gb
SSD for games: Crucial mx500 500gb
SSHD for games and general storage: Seagate Desktop SSHD 1TB

RAM: Corsair Vengeance LPX DDR4 3000 C15 2x8GB
XMP default profile is activated in bios. Intel c state is disabled.
Temps never go above 70 °C.

Here's a benchmark I ran on UserBenchmark:
https://www.userbenchmark.com/UserRun/15732837

Here are two different benchmarks I ran in Assassin's Creed: Odyssey, first with no stutters and second with a lot. Same settings and everything. Most games I try to run do this.
https://imgur.com/a/HgTsNXG
https://imgur.com/a/mIqyfk5

Link to comment
Share on other sites

Link to post
Share on other sites

I'm presuming you're using Windows - did you change the refresh rate in Windows after you got your new display?  If it's still set to 60Hz it could appear to be stuttering because 144 is not an integer multiple of 60 (i.e. 2.4 frames per pixel refresh).

 

If it's a gsync monitor, I can't help you because I have no experience with it, other than to tell you to try reinstalling your graphics drivers.

 

To change the refresh rate in Windows:

- Settings

- Display Settings

- Scroll down to Advanced Display Settings

- Change to Monitor tab

- Alter the screen refresh rate from 60Hz to 144Hz.

 

Also make sure you're using a high-speed HDMI cable or displayport cable.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×