Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC fails to post


PC specs:

Asus ROG STRIX b350 f motherboard 

Ryzen 5 1600 

2x 8gb 2400MHz ram OC to 2666


Cooler Master ML240L liquid cooler

EVGA BQ 600w semi modular


Last night I went into the bios to overclock my cpu and ram... I got my cpu to 3.95 GHz and my ram to 2666 MHz. Restarted, ran cinebench, worked fine.

Then I decided to update my bios through EZ Flash 3 using the internet option. I left it to update and when I came back, fans and lights were working but nothing on the monitor.

Turned PC on and off again and still nothing.

Removed CMOS battery and tried resetting the jumpers.

Removed the graphics card, reseated the ram, tried with only one stick and still nothing.

Anything I connect to the io doesn't work.

Looking at the Q-Leds, the dram led lights up but I think it's the motherboard. So I think it might be either my ram or motherboard is broken. Any idea what I should do?


Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now