Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Please Help! MEG x399 Creation: Windows Failed install and linux failed wifi

Hi Everyone,

I am new to Linux. However, I always wanted to have a dual boot windows/Linux computer, so I finally got myself one. The parts are listed here https://uk.pcpartpicker.com/list/GGcmvn 1. I updated the BIOS on that beast of a motherboard (I am planning on some major upgrades down the line). Also, like many others, LTT inspired me to build my rig (major cliche).

The parts arrived, and I assemble it, boot the bios, and everything was present, so I felt a huge relieve. I tried to install windows and Linux. However, I had the blue screen of death after the first installation section of windows (quite literally after the first reboot), which I thought was odd. So instead I started with Linux.

It crashed as soon as I log in (I asked for it to install third party proprietary software). After that, I install without that option, and It works like a charm.

However, the wifi card was not recognised (Intel® Wireless-AC 9260 card ), but the Bluetooth works flawlessly. I downloaded the Linux firmware from Intel, and I moved it to the /lib/firmware folder separately and also as individual files, and nothing worked.

I also updated all Linux packages, and everything and nothing has worked.

I am truly lost, any help will be great; also I am a complete Linux novice.

 

I hope it is not a motherboard failure, because I do not want to go through Amazon replacement speciality team. Does anyone have any ideas? I can program, but my skills are limited to data analysis and machine learning but do not extend further than pure analytics.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×