Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PLEASE HELP!

Go to solution Solved by b emoji,
10 minutes ago, mdmme said:

Hey so I got a model m off ebay and I completely took it apart to clean it. This includes taking apart the black plastic rivets on the back of the metal plate. When I put it back together most of the keys stopped working and have very little click and feel awful. Does anyone know how I can fix this or if I should just give up and buy another one?

Oh, I know exactly what youre talking about. You're gonna need to do a nut and bolt mod. The mod with hopefully make the board work again and feel a lot better, I did this to my blue badge m and it feels a lot more crisp after it. 

 https://wiki.geekhack.org/index.php?title=Modifications:IBM_Model_M:Nut_and_Bolt_Mod

Hey so I got a model m off ebay and I completely took it apart to clean it. This includes taking apart the black plastic rivets on the back of the metal plate. When I put it back together most of the keys stopped working and have very little click and feel awful. Does anyone know how I can fix this or if I should just give up and buy another one?

Link to comment
Share on other sites

Link to post
Share on other sites

Did you check by opening it again and seeing if you damaged anything or perhaps didn't reattach something all the way?

I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Skill Trident Z RGB - WD SN750 - Jedi Order Titan Xp - Hyper 212 Black (with RGB Riing flair) - EVGA G3 650W - dual booting Windows 10 and Linux - Black and green theme, Razer brainwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Dual Xeon X5560 - 24GB ECC DDR3 - GTX 750 TI - old Seagate 1.5TB HDD - dark mode Ubuntu (and Win7, cuz why not)

 

How many watts do I need? Seasonic Focus thread, PSU misconceptions, protections explainedgroup reg is bad

Link to comment
Share on other sites

Link to post
Share on other sites

10 minutes ago, mdmme said:

Hey so I got a model m off ebay and I completely took it apart to clean it. This includes taking apart the black plastic rivets on the back of the metal plate. When I put it back together most of the keys stopped working and have very little click and feel awful. Does anyone know how I can fix this or if I should just give up and buy another one?

Oh, I know exactly what youre talking about. You're gonna need to do a nut and bolt mod. The mod with hopefully make the board work again and feel a lot better, I did this to my blue badge m and it feels a lot more crisp after it. 

 https://wiki.geekhack.org/index.php?title=Modifications:IBM_Model_M:Nut_and_Bolt_Mod

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, mdmme said:

Hey so I got a model m off ebay and I completely took it apart to clean it. This includes taking apart the black plastic rivets on the back of the metal plate. When I put it back together most of the keys stopped working and have very little click and feel awful. Does anyone know how I can fix this or if I should just give up and buy another one?

Also what m did you get? The rainbow backplate space saver and industrial ones are real nice. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×