Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
DenisIosif

i need help guys

Recommended Posts

Posted · Original PosterOP

guys i need help i just buyed a new video card and idk why is not working the fan is working an on the monitor is black screen the video card is a amd r7 240 and i got a motherboard foxconn 2abf please help guys i ned help

Link to post
Share on other sites

Your motherboard is crappy cheap one. Your video card drain power from PCI-e and has no external power plug.

It's not something that should happens, but it happens sometimes. Your videocard is not compatible with your motherboard, even if should work in theory.

 

In worst case - you just bricked your motherboard.

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, homeap5 said:

Your motherboard is crappy cheap one. Your video card drain power from PCI-e and has no external power plug.

It's not something that should happens, but it happens sometimes. Your videocard is not compatible with your motherboard, even if should work in theory.

 

In worst case - you just bricked your motherboard.

aff fuck and i can run with my new video card

Link to post
Share on other sites

I confess, your motherboard is no better than a brick, and the video card is in about the same shape.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, kb5zue said:

I confess, your motherboard is no better than a brick, and the video card is in about the same shape.

yeah

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×